PGI and EPYC

Post Reply
sumseq
Posts: 141
Joined: Nov 27 2012

PGI and EPYC

Post by sumseq » Thu Nov 07, 2019 11:11 am

HI,

Is the new 19.10 PGI compiler compatible with the new EPYC Rome processors (including instruction set opts) such as the 7702P?

Are there any issues in compiling OpenACC GPU codes on a system with an AMD CPU?

- Ron

mkcolg
Posts: 8107
Joined: Jun 30 2004

Re: PGI and EPYC

Post by mkcolg » Fri Nov 08, 2019 8:03 am

Hi Ron,

We do support Rome, but since we rely on LLVM for the low level instruction selection, our support level depends on what LLVM support. PGI 19.10 ships with LLVM 8.0 with 9.0 expected to be added next year.

No, we have not seen any issues with compiling OpenACC GPU codes on AMD CPUs, and we do have AMD+NVIDIA GPU systems here that we use for testing.

-Mat

Post Reply