Compilation error in WRF 4.1.2

Questions on using the PGI Compilers and Tools
BartBrashers
Posts: 4
Joined: Dec 29 2017

Re: Compilation error in WRF 4.1.2

Post by BartBrashers » Mon Jan 06, 2020 6:41 pm

I can confirm this error still exists with pgfortran 19.10-0 LLVM 64-bit compiling WRF-4.1.3.

Any new ideas since the last posting?

mkcolg
Posts: 8382
Joined: Jun 30 2004

Re: Compilation error in WRF 4.1.2

Post by mkcolg » Tue Jan 07, 2020 11:06 am

Correct, we weren't able to get a fix in place for 19.10, but the issue should be address in our 20.1 release.

-Mat

aglobus
Posts: 194
Joined: Jun 11 2018

Re: Compilation error in WRF 4.1.2

Post by aglobus » Wed Mar 11, 2020 10:53 am

Should be corrected w/20.1

ssoong
Posts: 1
Joined: May 19 2020

Re: Compilation error in WRF 4.1.2

Post by ssoong » Thu May 21, 2020 12:33 am

I am using the community version (19.10) and I have the same ICE. I guess the next community version will not be release until later this year. Is there a way for me to use an older version like 19.5 so I can compile WRF4.1? Or is there another way to get around the problem?

mkcolg
Posts: 8382
Joined: Jun 30 2004

Re: Compilation error in WRF 4.1.2

Post by mkcolg » Thu May 21, 2020 8:41 am

Hi Ssoong,

No, archived releases are only available to Professional Edition License holders.

Note that PGI 20.4 is the last PGI branded release. We're transitioning the compilers to be part of the NVIDIA HPC SDK will be available for early access here soon (see https://developer.nvidia.com/hpc-sdk) . The first NV 20.5 early access release will have the fix for building WRF 4.1.2. There's no cost but does require registration. If you are unable to register, we will have twice yearly releases that do not require registration, with the first late this year.

Best Regards,
Mat

Post Reply