Can't post: constantly get 403 Forbidden error

Questions on using the PGI Compilers and Tools
ajp
Posts: 3
Joined: Sep 11 2019

Can't post: constantly get 403 Forbidden error

Post by ajp » Thu Sep 12, 2019 2:03 am

I do not seem to be able to write any length of post without getting a 403 forbidden error when previewing or submitting. It's massively frustrating. What's going on, it's just a simple text based post, a few hyperlinks, some source code, and some error messages. Is there a word limit or something.
New user to forum and new user to PGI: wasted a day trying to bisect my message to find the contaminated line with no luck: try@pgroup.com zero help either.

Help appreciated.
Andy

Thomas Zych
Posts: 1
Joined: Sep 11 2019

Re: Can't post: constantly get 403 Forbidden error

Post by Thomas Zych » Thu Sep 12, 2019 4:25 am

Looking at the two posts below yours at the moment, looks like some lowlifes are spamming the forum. Wonder if that has anything to do with it?

Also, how did you finally get *this* to post?

ajp
Posts: 3
Joined: Sep 11 2019

Re: Can't post: constantly get 403 Forbidden error

Post by ajp » Thu Sep 12, 2019 6:05 am

Yes, I thought someone might ask that. I found that a short post, no links, no code, no copy and past of terminal output, allowed me to press preview which worked, so I just hit submit. I even found that removing paragraph blank line separators made the difference between preview-able and not... It is reported elsewhere on the forum if you do a search for 403, I'd attached the link but...

I could really do with asking my questions as I'm quite stuck and need to progress.

mkcolg
Posts: 8048
Joined: Jun 30 2004

Re: Can't post: constantly get 403 Forbidden error

Post by mkcolg » Thu Sep 12, 2019 7:35 am

Yes, we have had an uptick in Spam posts recently. I delete them as soon as I see them. We do have all spam bot filters on, captcha enabled, and email confirmation to enable user accounts, but they still manually post them. Hopefully they'll get tired of it given I delete them within a few hours and lock the account. We're looking at what else we can do to combat them, but they're more just an annoyance at this point.

I don't think the 403 issues are related, but possible. Our web master has worked on this issue but I'll let him know it's still occurring. We can't replicate the issue so our current working theory is that it's a TLS/SSL issue on the client side.

-Mat

mkcolg
Posts: 8048
Joined: Jun 30 2004

Re: Can't post: constantly get 403 Forbidden error

Post by mkcolg » Thu Sep 12, 2019 7:39 am

FYI, the PGI Customer support email is trs@pgroup.com, not "try", or alternatively support@pgroup.com.

Feel free to send example code there.

Post Reply