PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Profiler default startup location

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Fri Jun 08, 2012 1:29 pm    Post subject: Profiler default startup location Reply with quote

Running Windows 7 64-bit.

Is there a way to set the startup default location of the profiler? It would save me a lot of path clicks moving up down etc.
Back to top
View user's profile
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Fri Jun 08, 2012 2:32 pm    Post subject: Reply with quote

Assuming you are starting the profiler from the "Start" menu, there is a way.
Code:
Click through the Start menu to "Start|All Programs|PGI Workstation|Debugger & Profiler"
Right-click on "PGPROF Performance Profiler"
Select "Properties"

The "Shortcut" tab should be displayed.
Code:
Enter the startup location you want in the box labeled "Start in:".

The same properties dialog can be used for desktop shortcuts as well. Let us know if this doesn't answer your question.
Back to top
View user's profile
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Fri Jun 08, 2012 4:07 pm    Post subject: Reply with quote

Thanks donb, I did all that but it doesn't work. Let me clarify to ensure I've asked the right question.

When I start the profiler and tell it to open a probile, I then need to specify the profiler output etc. It always starts at the desktop (even after I set the start in option to the place I want to start). How to I select a location other than the desktop?
Back to top
View user's profile
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Mon Jun 11, 2012 11:05 am    Post subject: Reply with quote

deepow,

It sounds as if you are seeing the file chooser start in the Desktop directory. Correct?

PGPROF uses the current directory as the starting point for the file chooser for both the pgprof.out file and the executable. The current directory is set by either the shortcut properties method described in the previous response or by 'cd' in a command shell and invoking the profiler from the command line.

Please answer a few questions to help us understand how you are encountering this issue:

(1) What version of PGI software are you using?

(2) How do you invoke the profiler?
- Start Menu?
- PGI Workstation bash shell command line?
- PGI Workstation command shell?
- Other?

(3) If it is from the command line, have you done a 'cd' to the folder/directory containing the pgprof.out file?

Note that setting the "Start in" directory for a shortcut only affects that shortcut - it doesn't affect other shortcuts to the profiler or the profiler executable properties.

Also, if the "Start in" directory contains a path to a non-existent directory (because the directory has been deleted or renamed since the shortcut property was set) then the directory will default to the desktop.

--donb
Back to top
View user's profile
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Mon Jun 11, 2012 12:47 pm    Post subject: Reply with quote

donb,

I was starting from a desktop shortcut (using Windows 7) and as you suggested, changing the "start in" within the shortcut properties did start the profiler where I wanted.

Thanks!


-ralph
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group