PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGI-style licensing not working

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
JohnRM



Joined: 19 Jul 2005
Posts: 2

PostPosted: Thu Jul 21, 2005 4:51 am    Post subject: PGI-style licensing not working Reply with quote

I am currently only wanting to take your compiler for a test drive.

I am using a 4-way Opteron board with Gentoo Linux (although that shouldn't really matter as I know my way around Linux very well.)

Issue 1. When I run the install script PGI provides, it does exactly what the instructions say it will, I then include which user the compiler will be licensed to and everything seems to go fine. But when I try and use the compiler, it gives me this error;

Code:

pgcc-linux86-64: LICENSE MANAGER PROBLEM: Cannot find license file.
 The license files (or license server system network addresses) attempted are
are listed below.  Use LM_LICENSE_FILE to use a different license file,
 or contact your software provider for a license file.
Feature:       pgcc-linux86-64
Filename:      ./license.dat
License path:  ./license.dat
FLEXnet Licensing error:-1,359.  System Error: 2 "No such file or directory"
For further information, refer to the FLEXnet Licensing End User Guide,
available at "www.macrovision.com".


Now that would be all fine and dandy if I was using Flex...but I'm not, nor do I wish to at the moment. I was trying to use the PGI-style licensing, and the instructions (much to my dismay) give no indication that ignoring the Flex instructions would cause an issue.

I would appreciate some assistance.

Thanks

John McClure
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Thu Jul 21, 2005 11:04 am    Post subject: Reply with quote

Hi John,

Once installed, you need to set-up your environment as described in section 1.3 of the 'INSTALL.txt' file that accompanies your installation (It can also be found here). The short version is that you need to set the PGI and LM_LICENSE_FILE environment variables, see below. Note that this presumes that selected 'yes' when asked if you want to create an evaluation license. If for some reason that a license.dat file was not created, please feel free to send a note to trs@pgroup.com and they will send you a temporary license file.

Thanks,
Mat

From INSTALL.txt:

...Assume the license file is in /usr/pgi/license.dat, ... Each user should do the following before running the compilers. In csh

% setenv PGI /usr/pgi
% setenv LM_LICENSE_FILE $PGI/license.dat
% set path = ($PGI/linux86/6.0/bin $path)
% setenv MANPATH $PGI/linux86/6.0/man

Or, assuming bash, sh or ksh:

% export PGI=/usr/pgi
% export PATH=$PGI/linux86/6.0/bin:$PATH
% export MANPATH=$PGI/linux86/6.0/man
% export LM_LICENSE_FILE=$PGI/license.dat

Note, be sure to change /usr/pgi to the actual location of your install, if different.
Back to top
View user's profile
JohnRM



Joined: 19 Jul 2005
Posts: 2

PostPosted: Thu Jul 21, 2005 10:30 pm    Post subject: Reply with quote

The order that you're supposed to do it in is off in your instructions that come with the download. You may want to give them in that exact order you just did here.

The order is important since I followed this order:

Code:

        % LM_LICENSE_FILE=/usr/pgi/license.dat
        % export LM_LICENSE_FILE
        % export PGI=/usr/pgi


and it didn't work.

Thanks for the correct order.

John
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Fri Jul 22, 2005 12:32 pm    Post subject: Reply with quote

Odd. Order shouldn't matter unless your using '$PGI' in the LM_LICENSE_FILE path. The commands you executed should work as well. Granted, the specific syntax depends on your shell.

Anyway, I'm glad your able to get things running.
- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group