PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Can't use CUDA in Visual Fortran
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
cu239



Joined: 20 Mar 2009
Posts: 14

PostPosted: Tue Aug 31, 2010 6:31 am    Post subject: Can't use CUDA in Visual Fortran Reply with quote

The build failed when I compiled a very simple CUDA fortran code (in .cuf). The compiler suggest:"pgnvd-Error-CUDADIR value is not a directory: f:\program files\pgi\win32/2010/cuda/2.3/bin" and "D:\ProgramsII\CUDA\Loop1\PVFProject3\Test2b.cuf(6) : error F0000 : Internal compiler error. pgnvd job exited with nonzero status code 0".

What does this mean?

My GPU is NVidia Geforce GTX460. Installed items are CUDA toolkit 3.1, NVidia GPU Computing SDK, and PGI Accelerator Visual Fortran 32-bit for VS2008 (release 10.8). The SDK samples are running correctly.

Anybody know this problem?

Thanks,
Bingray.
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Tue Aug 31, 2010 9:55 am    Post subject: Reply with quote

Hi,

How do you set your property in Visual Fortran? Did you choose from Project property page -> Fortran -> Language -> Enable Cuda Fortran and set CUDA Fortran Toolkit to 3.1?

Did you set any other property or flags? What OS do you have? Please try our matmul.CUF at http://www.pgroup.com/lit/samples/matmul.CUF and let us know it still fails. If you can post a simple program, we can try it here.

Thank you,
Hongyon
Back to top
View user's profile
cu239



Joined: 20 Mar 2009
Posts: 14

PostPosted: Wed Sep 01, 2010 2:03 am    Post subject: Reply with quote

Hi, Hongyon. Thanks a lot.

I did not set any of the property or flags. All properties are by default. After setting "Enable Cuda Fortran" to "Yes" and "CUDA Fortran Toolkit" to "3.1", the same problem still exists. I tried matmul.CUF and it fails with the same problem:

"pgnvd-Error-CUDADIR value is not a directory: f:\program files\pgi\win32/2010/cuda/3.1/bin"
"D:\ProgramsII\CUDA\Matmul\matmul.CUF(147) : error F0000 : Internal compiler error. pgnvd job exited with nonzero status code 0"

My OS is Microsoft Windows XP Professional Service Pack 3. VS2008 version is Microsoft Visual Studio Team System 2008 9.0.21022.8 RTM.

I installed CUDA and PGI CUDA Fortran in disk (F:). Will it be better if I install them in (C:)?

My simple program:
!=====================================
module allvar
real, constant :: dte,nstep
end module allvar

program prog
use cudafor
implicit none
integer,parameter :: im=800000
real, device :: a(im)
call a05<<<im/256,256>>>(a,im)
end program prog

! Kernel definition
attributes(global) subroutine a05( a, n)
implicit none
real, dimension(*) :: a
integer, value :: n,i
i = (blockidx%x-1) * blockdim%x + threadidx%x
if( i <= n ) a(i) = float(i)*0.5
end subroutine
!=====================================

Thank you very much.
Bingray
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Wed Sep 01, 2010 7:29 am    Post subject: Reply with quote

Hi,

Does this fail if you invoke from command line? I just want to narrow down if this is PVF issue or something else.

To try from command line,
Open up PGI Visual Fortran->Command Shells->PVF 208 Cmds(64), then type following at command prompt.

%pgfortran -Mcuda matmul.CUF

I will let you know asap if install on F disk might cause a problem.

Thank you,
Hongyon
Back to top
View user's profile
cu239



Joined: 20 Mar 2009
Posts: 14

PostPosted: Wed Sep 01, 2010 9:55 pm    Post subject: Reply with quote

Hi, Hongyon:

In PGI Visual Fortran->Command Shells->PVF 208 Cmds, it still fails:

===============================================
D:\ProgramsII\CUDA\Matmul>"f:\program files\pgi\win32\10.8\bin\pgfortran.exe" -Mcuda matmul.CUF
NOTE: your trial license will expire in 2 days, 11.4 hours.
NOTE: your trial license will expire in 2 days, 11.4 hours.
pgnvd-Error-CUDADIR value is not a directory: f:\program files\pgi\win32/2010/cuda/2.3/bin
PGF90-F-0000-Internal compiler error. pgnvd job exited with nonzero status code 0 <matmul.CUF: 147>
PGF90/x86 Windows 10.8-0: compilation aborted

D:\ProgramsII\CUDA\Matmul>
===============================================

Thank you again,
Bingray
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group