PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Linking using different mpi libraries

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
adityak



Joined: 19 Mar 2007
Posts: 10

PostPosted: Tue Mar 27, 2007 9:22 am    Post subject: Linking using different mpi libraries Reply with quote

Hi,
Can you tell me how I can use the pgcc, pgf77 compilers to link to a different mpi library (Since I cannot use the PGI mpi library for an Infiniband cluster). Although the environment path contains a folder in which the other mpi libraries are present, the compiler gives me an error saying it cannot find MPI_Init.

Thanks
Aditya
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6119
Location: The Portland Group Inc.

PostPosted: Thu Mar 29, 2007 11:12 am    Post subject: Reply with quote

Hi adityak,

We're still in the process of getting an infiniband cluster here in-house so I don't have personal experience building MPI for inifiniband. However, I do know others who have successfully built OpenMPI (http://www.open-mpi.org/) using the PGI compilers.

See: http://www.open-mpi.org/faq/?category=building#build-compilers
and http://www.open-mpi.org/faq/?category=building#build-p2p

Hope this helps,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group