PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Problem running mpirun from head node in cluster
Goto page Previous  1, 2
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Thu Mar 22, 2007 4:26 pm    Post subject: Reply with quote

Hi Aditya,

Our PGI CDK is not configured or supported Infiniband cluster yet. However, I believe you can use the mpi scripts and libraries that comes with the cluster which supports Infiniband cluster, which, you say, are in /usr/bin.

I have looked up online, they say you can configure the mpi scripts in /usr/bin to use PGI compilers or any compilers by edit the mpicc/mpiCC/mpif90/mpif77 scripts. Then, you might want to set path to just point to PGI compilers, but not set it to PGI CDK MPI because you will use MPI libraries which comes with the Infiniband, I guess. Again, I am not really sure what the scripts look like or what MPI libraries come with it since we don't have Infinipath in house.

We are getting Infiniband cluster up and running in a few days, if above info. does not work for you. We will post more information that might help.

Hongyon
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group