PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGI 6.1-6 installation error on FC5

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
orola



Joined: 02 Apr 2005
Posts: 3

PostPosted: Mon Aug 28, 2006 9:54 pm    Post subject: PGI 6.1-6 installation error on FC5 Reply with quote

Hello, When installing PGI6.1.6 on my computer,of wich the OS is FC5, there is error: " usr/pgi/linux86/6.1/bin/makelocalrc: line 64:strings:command not found ERROR:unknown glibc version()". Would you please help me to fix the problem? THank you very much!
Back to top
View user's profile
orola



Joined: 02 Apr 2005
Posts: 3

PostPosted: Mon Aug 28, 2006 10:34 pm    Post subject: Reply with quote

in the directory /lib/ there are two libc files maybe related to this problem libc-2.4.so ,and lib.so.6 ,which is a link to lib-2.4.so. I think that means my glibc version is 2.4,and pgi 6.1.6 do not support glibc2.4.Is there any way to solve this problem? Could I install an older version of glibc on my computer?
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Tue Aug 29, 2006 2:46 pm    Post subject: Reply with quote

Hi orola,

The script is using a Linux utility called 'strings' to search which GLIBC you have installed on the systems. It appears that 'strings' might be missing from your system. What's the output of the following commands?
Code:
type strings
ls -l /usr/bin/strings

If 'strings' exists in /usr/bin, but type can't find it, add /usr/bin to your PATH environment variable. If 'strings' doesn't exists, you'll need to install the 'binutils' RPM package from your FC5 installation disks.

- Mat
Back to top
View user's profile
orola



Joined: 02 Apr 2005
Posts: 3

PostPosted: Tue Aug 29, 2006 11:26 pm    Post subject: PGI 6.1-6 installation error on FC5 Reply with quote

HI mkcolg,
Thank you very much! I have checked the "strings",followed instructions by you, and "strings"does not exist. Then I try to upgrade the FC5 system, this time "binutils" is suscessfully installed.
But when to install PGI ,it give error that gcc not found. so I go back to check the install.log and upgrade.log of my system, the firstline of the files print:
"Installing libgcc-4.1.0-3.i386
warning: libgcc-4.1.0-3.i386 : V3 DSA signature: NOKEY, key ID db42a60e"
also ,I have tried command line "rpm -ivh libgcc-4.1.0-3.i386.rpm", but still failed.
I do not know what is wrong,would you help me to sovle it?
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group