PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Seg fault profiling program using mcmodel=medium

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
LisaD



Joined: 25 Jul 2006
Posts: 3

PostPosted: Mon Jul 31, 2006 1:11 pm    Post subject: Seg fault profiling program using mcmodel=medium Reply with quote

I have a mixed Fortran/C program compiled with mcmodel=medium that I am trying to profile. When I use -Mprof=func, the program seg faults immediately. I used a small Fortran/C program for testing and found that when I remove mcmodel=medium, the program ran and produced profiling results. Does the profiler not work with mcmodel=medium? (I am using the 6.1 x86-64 compiler on SLES 9 - I also had the problem with the 5.2 compiler)

-Lisa
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Mon Jul 31, 2006 2:56 pm    Post subject: Reply with quote

Hi Lisa,

Unfortunately, the 6.1 compiler does not support Profiling using "-mcmodel=medium" (See page 45 of the PGI 6.1-6 Release notes). We are looking at ways to support this feature, but I'm not sure if it will be available in the up-coming 6.2 release.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group