PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Memory fault with pgi-6.1 but not pgi-5.2.2/

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
Bernd_J



Joined: 11 Jul 2006
Posts: 1

PostPosted: Tue Jul 11, 2006 5:50 am    Post subject: Memory fault with pgi-6.1 but not pgi-5.2.2/ Reply with quote

A serial program works fine with pgi-5.2.2/ and options -O1 -r8 -i8
the same source source with 6.1 and -O1 -r8 -i8 -tp p7-64
compiles with the same warnings as in the first case, but the program terminates in the second iteration with a memory fault and a core dump.

The error happens at the same place (when a program mixb.x is called for the 2nd time).
To find the fault I open a File after the declarations and write something into this file in the next line. In the first iteration the file is created and the text is written into the file. In the second iteration ther program crashes and the file is empty with the actual time, so it seems that the file-access causes the error.

Any suggestions how to find and solve the problem?

Thanks in advance, Bernd.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6129
Location: The Portland Group Inc.

PostPosted: Tue Jul 11, 2006 11:32 am    Post subject: Reply with quote

Hi Bernd,

Can you post a small example or send a report to trs@pgroup.com? It's unclear to me what the issue would be and a code sample would help.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group