PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

required glibc version
Goto page 1, 2  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
kus



Joined: 14 Jul 2005
Posts: 3

PostPosted: Sun Oct 20, 2013 7:27 am    Post subject: required glibc version Reply with quote

I have PGI 13.7 Accelerartor Fortran installed under Open SUSE 11.4 w/glibc 2.6.1. The compiler works, but we did not check cuda-5.0-based extensions.

According 13.7 Installation Guide even SuSE 9.3 w/glibc 2.3.4 must work w/compiler.
But yesterday I tried to install CUDA 5.0 Toolkit Samples and it says that glibc 2.14 is required for example for some libcudart.so modules.

What is really about glibc requirements for 13.7 cuda-based extensions ?

Mikhail
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6119
Location: The Portland Group Inc.

PostPosted: Mon Oct 21, 2013 12:32 pm    Post subject: Reply with quote

Hi Mikhail,

The CUDA Toolkit is a separate and may have differing requirements than the PGI Fortran compilers.

PGI ships all necessary components to build CUDA Fortran. There was a problem in 13.7 on older systems when targeting CUDA 5.0 due to a header file issue, but this was fixed in 13.9 when we moved to CUDA 5.0 by default. Of course, if you are unable to install the CUDA 5.0 drivers on your system, then any CUDA Fortran program built using CUDA 5.0 wont run.

- Mat
Back to top
View user's profile
kus



Joined: 14 Jul 2005
Posts: 3

PostPosted: Thu Oct 24, 2013 11:45 am    Post subject: Reply with quote

mkcolg wrote:
Hi Mikhail,

The CUDA Toolkit is a separate and may have differing requirements than the PGI Fortran compilers.

Yes, I understand that CUDA is different product. But I'm afraid potentially different requirements of PGI CUDA Fortran and corresponding CUDA version itself. Should I understand you that there is no requirements of glibc 2.4 or higher from PGI 13.7 (or even 13.9) ?

mkcolg wrote:
PGI ships all necessary components to build CUDA Fortran. There was a problem in 13.7 on older systems when targeting CUDA 5.0 due to a header file issue, but this was fixed in 13.9 when we moved to CUDA 5.0 by default. Of course, if you are unable to install the CUDA 5.0 drivers on your system, then any CUDA Fortran program built using CUDA 5.0 wont run.

- Mat


New NVIDIA kernel driver (nvidia.ko) was installed independently. It looks that it works OK (nvidia-smi works successfully).
But what is about OGI CUDA Fortran glibc requirement ?

Mikhail
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6119
Location: The Portland Group Inc.

PostPosted: Fri Oct 25, 2013 9:48 am    Post subject: Reply with quote

Hi Mikhail,

For PGI components, you can find out which Linux versions are supported by which compiler versions at: http://www.pgroup.com/support/install.htm#linux_info.

Non-PGI components, such as CUDA and ACML, may have different requirements. However, in the case of CUDA, this is one reason why we ship multiple versions of the tool kit.

- Mat
Back to top
View user's profile
kus



Joined: 14 Jul 2005
Posts: 3

PostPosted: Sat Oct 26, 2013 7:55 pm    Post subject: glibc requirements Reply with quote

mkcolg wrote:
Hi Mikhail,

For PGI components, you can find out which Linux versions are supported by which compiler versions at: http://www.pgroup.com/support/install.htm#linux_info.

OpenSuSE 11.2 and 12.2 are supported.
I have 11.4 (where PGI 13.7 w/cuda extension is installed) and new HDD w/12.3, where PGI isn't installed - but potentially I may move it to this HDD.
Is this supported Linux list for whole product - i.e. for PGI Fortran w/CUDA extensions ? If the answer is "yes", my glibc version in SUSE 11.4 is higher than in officially supported 11.2, and practically PGI 13.7 w/cuda extensions must work.

If "no", are glibc requirements found by me for cuda toolkit 5.0 Samples under OpenSuSE 11.4 important for PGI cuda components ?

It's the question not about CUDA - it's the question for whole PGI product I purchased.


mkcolg wrote:

Non-PGI components, such as CUDA and ACML, may have different requirements. However, in the case of CUDA, this is one reason why we ship multiple versions of the tool kit.

- Mat


There is no clear system requirements for CUDA.
I installed on new HDD on server w/K20c and OpenSUSE 12.3
:CUDA 5.5 (Toolkit works including Samples) - but PGI is based on 5.0

:CUDA 5.0 (toolkit was installed after suppressing of some checks - including gcc, but Samples reject gcc 4.7 as unsupported and don't works)

I don't know, shold I pay attention on cuda Samples for PGI fortran w/cuda ??
Unfortunately I myself can't check 13.7 installed for work w/cuda extensions - I'm not familiar with this features.

Thanks for help !
Mikhail
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group