PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

cannot find -lcuda

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
brush



Joined: 26 Jun 2012
Posts: 44

PostPosted: Sun Jan 12, 2014 6:06 pm    Post subject: cannot find -lcuda Reply with quote

Hi, normally I just use OpenACC on my machine but I wanted to add some CUDA. When I tried to compile one of the programs that comes with the installation, I get

ben@birdsall:~$ make deviceQuery
pgfortran -fast -o deviceQuery deviceQuery.cuf
/usr/bin/ld: cannot find -lcuda
make: *** [deviceQuery] Error 2

Thanks.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Mon Jan 13, 2014 10:00 am    Post subject: Reply with quote

Hi Brush,

In the 13.1 release we added the CUDA driver library (-lcuda) to the link, but decided that it wasn't necessary for the build and caused problems for folks who were building on systems without the CUDA driver installed. Hence, in 13.6 we removed it from the link.

I'm assuming you're using a release 13.1 - 13.5? If so, the work around is to install the CUDA Drivers (https://developer.nvidia.com/cuda-downloads).

Best Regards,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group