PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Compiled Fortran executable file can't run on other machines
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
lukeStar



Joined: 02 Mar 2011
Posts: 20

PostPosted: Wed May 08, 2013 3:13 pm    Post subject: Compiled Fortran executable file can't run on other machines Reply with quote

I have a Fortran code compiled using PGI Visual Fotran 13.4 in Win 7 (64 bit) os. It can run on the laptop compiling it, but can't run on other machines.
I didn't expect this happen. IT seems the compiled code not portable.

Anyone can help me? Thanks a lot in advance!
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Wed May 08, 2013 4:13 pm    Post subject: Reply with quote

Quote:
It can run on the laptop compiling it, but can't run on other machines.
Can you describe the error you get when running on the other machines? What OS are the other machines running?

Quote:
IT seems the compiled code not portable.
How did they compile it?

- Mat
Back to top
View user's profile
lukeStar



Joined: 02 Mar 2011
Posts: 20

PostPosted: Wed May 08, 2013 5:58 pm    Post subject: Reply with quote

It is the same as my laptop: Win 7 (64bit).
When clicking the executable file, a error message popup like An error occurred for this program and windows is checking solution...
Back to top
View user's profile
lukeStar



Joined: 02 Mar 2011
Posts: 20

PostPosted: Wed May 08, 2013 6:00 pm    Post subject: Reply with quote

This is a pure Fortran code without CUDA. I complied it using O-3 option and it runs well in my laptop. I don't know what's wrong with the compiler or the compiling settings.
Back to top
View user's profile
lukeStar



Joined: 02 Mar 2011
Posts: 20

PostPosted: Wed May 08, 2013 7:03 pm    Post subject: Reply with quote

Both are Intel core i7.

I used the default values for almost all the compiling settings except the option maximum speed optimization option was selected.

Previously, the same code was compiled using Compaq Fortran and the executable file could be run on both computers without any problems.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group