PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Course

unable to download or install PVF 13.2
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
mkcolg



Joined: 30 Jun 2004
Posts: 6630
Location: The Portland Group Inc.

PostPosted: Thu Feb 28, 2013 12:37 pm    Post subject: Reply with quote

Quote:
does that mean the last update was the 2/19? I have installed it after and I am still having issues with Windows 8 and VS 2010
Yes, the last update was 2/19. Let me ask one of our PVF engineers to jump in here since I'm not sure.

- Mat
Back to top
View user's profile
ams



Joined: 14 Jul 2004
Posts: 41

PostPosted: Thu Feb 28, 2013 1:05 pm    Post subject: Reply with quote

Hi Dolf,

Have you had PVF installed on this system before? Have you installed PVF on other systems?

What version of VS 2010 are you using (i.e., professional, premium), which build (i.e., RTM, SP1) and what languages do you have installed? You should be able to see all of this from the VS 2010 Help | About menu.
Back to top
View user's profile
Dolf



Joined: 22 Mar 2012
Posts: 145

PostPosted: Mon Mar 04, 2013 4:48 pm    Post subject: RE: Reply with quote

Quote:
Have you had PVF installed on this system before? Have you installed PVF on other systems?

I have installed the PGI on windows 7 with VS 2010 on my old i7 machine.
I am able to install a evaluation copy of 13.2 (part of academic offer from PGI license that will end in Aug. 2013)
Visual Studio 2010 Premium
Ver. 10.0 RTMRel
Windows 8, Dell XPS 8500, GeForce 680 GPU
when I compile a simple code such as:

program test1
use cudafor
implicit none

real(8), device :: aDev

end program test1

I get this warning and error:

C:\Users\Dolf\Desktop\test1\SourceFile1.f90(0) : warning W0471 : CUDA Fortran feature license not found; CUDA Fortran features disabled
C:\Users\Dolf\Desktop\test1\SourceFile1.f90(12) : error S0034 : Syntax error at or near device

do you know why Cuda features are disabled? how can I run my code into GPU??

thanks!

Dolf
Back to top
View user's profile
ams



Joined: 14 Jul 2004
Posts: 41

PostPosted: Mon Mar 04, 2013 5:07 pm    Post subject: Reply with quote

Glad to hear that PVF is working for you now. I'm assuming this issue is closed; please let me know if that's not correct.

Regarding licensing: the PVF academic evaluation offer you're using does not include accelerator features. You can get a 15-day trial license for the accelerator features from our sales department though. Contact sales@pgroup.com with your PGI account information and let them know that you're using the PVF academic license but want to try the accelerator features too.
Back to top
View user's profile
Dolf



Joined: 22 Mar 2012
Posts: 145

PostPosted: Mon Mar 04, 2013 6:34 pm    Post subject: RE: Reply with quote

Hi,
Yes, I did install the 15 days trail license as administrator, now when I compile the code, I get this error the the compiler stops:

error LNK2019: unresolved external symbol MAIN_ referenced in function main

why do you think this is happening??

Dolf
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group