PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

startup error with C++ libraries

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
schwieters



Joined: 29 Jul 2004
Posts: 1

PostPosted: Tue Aug 03, 2004 6:54 am    Post subject: startup error with C++ libraries Reply with quote

I have an application linked against multiple shared libraries containing C++ code (all compiled with pgCC, of course).

At program startup I get:
C++ runtime abort: internal error: static object marked for destruction more than once
Abort

any hints as to how I should look for the cause?

platform: ia32
compiler version: 5.2

thanks--
Charles
Back to top
View user's profile
mleair



Joined: 19 Jul 2004
Posts: 67
Location: Portland Group

PostPosted: Wed Aug 04, 2004 1:51 pm    Post subject: RE: C++ runtime error Reply with quote

Hi,

What happens if you statically link in your libraries using -Bstatic?

Regards,

Mark
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Wed Aug 04, 2004 2:25 pm    Post subject: Reply with quote

You might want to look in your constructor(s) first. If you don't have one, you need one if you are dealing with pointers. I assume in your destructor(s) you have some "delete" to deallocate memory. Make sure you initialize all pointers to 0 or NULL in your constructor(s).
Hope this help.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group