PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Determining running timing problem
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Tue May 01, 2012 2:52 pm    Post subject: Reply with quote

By the way, here is compiler command line:

-Bstatic -Mbackslash -Mbounds -Mchkptr -Mchkstk -I"F:\Macro3d\Macro3d_PGI\Include Files" -I"d:\program files\pgi\win64\12.4\include" -I"D:\Program Files\PGI\Microsoft Open Tools 10\include" -I"D:\Program Files\PGI\Microsoft Open Tools 10\PlatformSDK\include" -fastsse -Ktrap=fp -tp=nehalem-64 -Minform=warn -Minfo=ftn,mp
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6218
Location: The Portland Group Inc.

PostPosted: Tue May 01, 2012 3:47 pm    Post subject: Reply with quote

Looks like there are some missing bits (input and solve routines as well as the input workload) so I can't recreate the test. Mind zipping up all the necessary files and sending it to PGI Customer Service (trs@pgroup.com) and ask them to forward it to me?

- Mat
Back to top
View user's profile
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Tue May 01, 2012 3:56 pm    Post subject: Reply with quote

Mat, I'll do that.

I have a problem with the web site in that I can't change my profile so it'll tell me when a reply has been posted. (Want my email address but no where to put it into the profile.) I've sent a message to the webmaster but no reply, I'm not sure how often he/she checks messages. Currently I have to load the forum back into my browser to check to see if you've replied.

Sorry to ask. It is straight forward to do login etc. but a pain in the a$$.
Back to top
View user's profile
deeppow



Joined: 02 Feb 2012
Posts: 51

PostPosted: Tue May 01, 2012 4:32 pm    Post subject: Reply with quote

Have sent the whole code to support. No further distribution please.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6218
Location: The Portland Group Inc.

PostPosted: Wed May 02, 2012 8:22 am    Post subject: Reply with quote

Quote:
I can't change my profile so it'll tell me when a reply has been posted.
I don't think he enabled this feature. Though, I'll talk with him to see what can be done.

Code:
No further distribution please.
Understood.


For what ever reason, the CPU time I get seems correct. I'm not sure why you would be getting zeros. Is your timing section running below 1 second?

AMD Bulldozer system running Win Server 2008
Quote:
Total CPU time is 3.121400070E+01 sec = 5.2023339E-01 min = 8.67056E-03 hr


Intel Sandy-Bridge System running Win7 SP1.
Quote:
Total CPU time is 1.582100010E+01 sec = 2.6368335E-01 min = 4.39472E-03 hr


- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group