PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Compilation problem
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
stormlab



Joined: 23 Jul 2005
Posts: 28

PostPosted: Thu Sep 15, 2005 4:35 am    Post subject: pregrid Reply with quote

Hi Mat,

Thank you for your time and help.

> In the mean time, if you could isolate where the violation occur, it would be > very helpful.

Do you mean to use some debugger? I have debugger of Borland C++ Builder 6.0 but I don't know much about how to use it (I'm not good at the asembler;) (mov, eax...etc.) What I understand is the address location of the access violation.

Angel
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6213
Location: The Portland Group Inc.

PostPosted: Thu Sep 15, 2005 3:19 pm    Post subject: Reply with quote

Try using gdb since we bundle it with the Win32 compilers. First compile Pregidder with "-g" and then run it through gdb ('gdb pregridder.exe'). Once gdb starts up run pregridder by typing 'run <args>' where args is the command line arguments you normally run pregridder with. Once the access violation occurs type 'where' to get a stacktrace. This should give to the exact line number where the violation occurs.

- Mat
Back to top
View user's profile
stormlab



Joined: 23 Jul 2005
Posts: 28

PostPosted: Sat Sep 17, 2005 3:58 am    Post subject: gdb Reply with quote

Hi Mat,

I tried to compile the pregrid with option -g but with no success. I get error while compiling the code:

The instruction at "0x004c57ef" referenced memory at "0x000004a4". The memory could not be "read".

Is this a compiler problem or the source code is not good?

Angel
Back to top
View user's profile
stormlab



Joined: 23 Jul 2005
Posts: 28

PostPosted: Thu Sep 22, 2005 1:54 am    Post subject: pregrid/MM5 Reply with quote

Hi Mat,

Did you have time to try to compile pregrid(MM5) and to run it? Option -g gives me error while compiling.

I know that you are busy so no problems if you aren't able now;)

Thanks!

Angel
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6213
Location: The Portland Group Inc.

PostPosted: Thu Sep 22, 2005 3:40 pm    Post subject: Reply with quote

Hi Angel,

My fault. I forgot that "-g" isn't supported on win32. Anyway...

I was able to build pregridder/regridder. Can you walk me through what steps you did to run program? I don't have data, so if you point me somewhere I can download an exmample set I'd appreciate it.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group