PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

unresolved external symbol

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
mcoffey



Joined: 26 Mar 2011
Posts: 16

PostPosted: Thu Oct 06, 2011 12:48 pm    Post subject: unresolved external symbol Reply with quote

Mat, when I compile and run the source I sent you the other day with
"c:\Program Files\PGI\win32\11.8\bin\pgf95.exe" -Mcuda=cuda4.0,cc11 -Minfo -o mgeno2.exe mgeno2.f90

everything works fine
but when I include
"c:\Program Files\PGI\win32\11.8\bin\pgf95.exe" -ta=nvidia:cuda4.0 -Mcuda=cuda4.0,cc11 -Minfo -o mgeno2.exe mgeno2.f90

I get unresolved external symbol. Ive tried it on a few other files and the same thing occurs.

When the main file contains some pragmas to create accelorator kernels and the file has a kernel and the -ta=nvidia... and the -Mcuda=...is on the compile line it creates that error.
I know in the previous post you said you can use -ta=nvidia and -Mcuda as long as you include 4.0 since -Mcuda defaults to 3.2 so I have. Im not sure what is causing the error so am not sure where to start changing things (especially since it works perfectly without -ta=...)

Thanks
Mike
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6218
Location: The Portland Group Inc.

PostPosted: Thu Oct 06, 2011 2:01 pm    Post subject: Reply with quote

Hi Mike,

These look like the same errors from TPR#18202 (See: http://www.pgroup.com/userforum/viewtopic.php?t=2813) reported a few days ago. We have a fix in place, unfortunately though, it was not in time for today's 11.9 release so wont be available till December's 12.0 release.

The problem has to do with how Win32 symbols are decorated. Hence, a work around would be use a 64-bit Windows, or Linux system.

I do apologize for the error.

Best Regards,
Mat
Back to top
View user's profile
mcoffey



Joined: 26 Mar 2011
Posts: 16

PostPosted: Thu Oct 06, 2011 10:01 pm    Post subject: Reply with quote

thanks Mat, at least knowing that will stop me keep trying to solve it!

Mike
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group