PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

warning: missing terminating ' character

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
TheMatt



Joined: 06 Jul 2009
Posts: 317
Location: Greenbelt, MD

PostPosted: Mon Apr 04, 2011 4:40 am    Post subject: warning: missing terminating ' character Reply with quote

A system I use recently upgraded to PGI 11.3. In doing so I noticed a jillion of these warnings:
Code:
warning: missing terminating ' character
every time I compile my model. I never see these with 11.2 on a different machine.

It's due to the fact that some comments in the code use apostrophes:
Code:
96 !  Estimate of friction velocity from previous step's drag coefficient

Is there any way to suppress these warnings without suppressing all non-severe warnings? (Or, if nothing changed between 11.2 and 11.3, could there be some environment variable I have set that is making these appear on the 11.3 machine and not on the 11.2?)

Thanks,
Matt
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6129
Location: The Portland Group Inc.

PostPosted: Mon Apr 04, 2011 11:58 am    Post subject: Reply with quote

Hi Matt,

It's not one of our warnings and in searching the web, it looks like it might be coming from cpp. Though, I can't seem to get my version of cpp to emit the error so am not sure how to tunr if off (or in my case enable it).

- Mat
Back to top
View user's profile
TheMatt



Joined: 06 Jul 2009
Posts: 317
Location: Greenbelt, MD

PostPosted: Mon Apr 04, 2011 12:10 pm    Post subject: Reply with quote

mkcolg wrote:
It's not one of our warnings and in searching the web, it looks like it might be coming from cpp. Though, I can't seem to get my version of cpp to emit the error so am not sure how to tunr if off (or in my case enable it).

Hmm. Glad to know it wasn't anything wrong with PGI. The SLES I'm using has:
Code:

> rpm -q cpp
cpp-4.3-62.198

Looking at gcc-4.3.5 from GCC's site, I do see in libcpp/lex.c:
Code:
 661   if (type == CPP_OTHER && CPP_OPTION (pfile, lang) != CLK_ASM)
 662     cpp_error (pfile, CPP_DL_PEDWARN, "missing terminating %c character",
 663           (int) terminator);
That said, I'm not sure if it should be triggering in comments...

Ah well, as long as it's a warning, no bother.

Matt
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group