PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGF90-F-0000-Internal compiler error. module:new_dtype, dt n

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
Taewon



Joined: 09 Apr 2011
Posts: 2

PostPosted: Sat Apr 09, 2011 12:28 pm    Post subject: PGF90-F-0000-Internal compiler error. module:new_dtype, dt n Reply with quote

When compiling programs under linux using PGI fortran 7.0-5,
the following error occurs (error message is bold):

mpif90 -c -I. -I/opt/netcdf/include -I/opt/netcdf/include -I/opt/mpich2/include -I. -I/data/tpark40/model/cesm1_0_2/case/test4/SourceMods/src.cice -I/data/tpark40/model/cesm1_0_2/models/ice/cice/src/drivers/cpl_mct -I/data/tpark40/model/cesm1_0_2/models/ice/cice/src/drivers/cpl_share -I/data/tpark40/model/cesm1_0_2/models/ice/cice/src/mpi -I/data/tpark40/model/cesm1_0_2/models/ice/cice/src/source -I/data/tpark40/model/cesm1_0_2/exe/test4/lib/include -DCCSMCOUPLED -Dcoupled -Dncdf -DNCAT=1 -DNXGLOB=144 -DNYGLOB=96 -DNTR_AERO=0 -DBLCKX=18 -DBLCKY=96 -DMXBLCKS=1 -DMCT_INTERFACE -DHAVE_MPI -DCO2A -DLINUX -DSEQ_ -DFORTRANUNDERSCORE -DNO_SHR_VMATH -i4 -gopt -Mlist -Mextend -byteswapio -Mflushz -Kieee -Ktrap=fp -O2 -Mvect=nosse -Kieee -Mfree /data/tpark40/model/cesm1_0_2/models/ice/cice/src/source/ice_therm_vertical.F90
PGF90-F-0000-Internal compiler error. module:new_dtype, dt nfd 2293
(/data/tpark40/model/cesm1_0_2/models/ice/cice/src/source/ice_therm_vertical.F90: 37)
PGF90/x86-64 Linux 7.0-5: compilation aborted


I find that this error message is a compiler bug that has to be fixed by PGI in google search.

When using PGI fortran 7.1-3, the same error occurred.
I want to know whether the error is fixed or not in later version of PGI fortran.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6129
Location: The Portland Group Inc.

PostPosted: Mon Apr 11, 2011 11:20 am    Post subject: Reply with quote

Hi Taewon,

Quote:
I find that this error message is a compiler bug that has to be fixed by PGI in google search
In looking through our old issue reports, I do see a similar error (TPR#4221) that was reported in the 7.0-5 compiler and fixed in 7.0-7. However, this is a generic error so I don't know if this is the exact same issue that you are encountering.

My guess is that this error has been fixed given this compiler is 4 years old, we have had no reports of similar issues and I recently built the CICE from CCSM4.0.

Though, to be sure I'd like to try and recreate your issue. Which version of CICE are you using?

Thanks,
Mat
Back to top
View user's profile
Taewon



Joined: 09 Apr 2011
Posts: 2

PostPosted: Mon Apr 11, 2011 11:53 am    Post subject: Reply with quote

Hi, Mat.

Thanks a lot for your reply.

I used CICE4 which is a component of CESM1.

And, I tried to build the CICE from CCSM4.0, but the same error occurred.

Maybe, the low version of PGI Fortran in my linux server is the reason of the error.

I will try to compile it using the latest version.

Taewon.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group