PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Missing axlib

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
mmarc__



Joined: 01 May 2010
Posts: 5

PostPosted: Thu Mar 24, 2011 4:47 am    Post subject: Missing axlib Reply with quote

Hi,

I have the following error:

pgf90-Error-Version axlib is not available in this installation

To my understanding, the code that fails with this message does not contain anything special. Why axlib is needed, what does it provide?

Thanks,
- D.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6146
Location: The Portland Group Inc.

PostPosted: Thu Mar 24, 2011 8:51 am    Post subject: Reply with quote

Hi D,

The "-V" flag selects the compiler version. My guess is that you have compile flag "-Vaxlib" so the compiler is looking for Version axlib which doesn't exist. Do you know what "axlib" is? Is is a library or library directory? If so, then the flag should be "-laxlib" or "-Laxlib".

Hope this helps,
Mat
Back to top
View user's profile
mmarc__



Joined: 01 May 2010
Posts: 5

PostPosted: Thu Mar 24, 2011 10:22 am    Post subject: Reply with quote

Oh, clear now, shameful mistake. That was created by mysterious -Vaxlib in one of the libraries' compile options.

Thanks, Mat!
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group