PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Course

do pgi fortran supports cula ?

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
lyh



Joined: 24 May 2011
Posts: 2

PostPosted: Tue May 24, 2011 6:25 pm    Post subject: do pgi fortran supports cula ? Reply with quote

vs2010+pgi fortran

configure the environment

1.globle setting
select tools>options>project and solutions>pvf directories,configure global exextable,include,and library paths
2.project setting
configuration properties>linker>input. in the additional dependences field ,enter "libcula_pgfortan.lib"
3.runtime path
copy cula.dlland its's dlls to the working directory

but when i run the program there are errors::like this

SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_INITIALIZE@0 referenced in function _MAIN_
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_SGEQRF@20 referenced in function _MAIN_
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_SHUTDOWN@0 referenced in function _MAIN_
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_GETERRORINFO@0 referenced in function _CHECK_STATUS@4
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_GETSTATUSSTRING@4 referenced in function _CHECK_STATUS@4

can you help me?
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6631
Location: The Portland Group Inc.

PostPosted: Wed May 25, 2011 3:04 pm    Post subject: Reply with quote

Hi Lyh,

Try the following settings instead:

1) Linker | General | Additional Library Directories

Put the path to the CULA library directory

2) Linker | Input | Additional Dependencies

Put the name of the CULA library, i.e., libcula_pgfortran.lib

3) Debugging | Environment

Add the path to the CULA DLLs to the PATH environment variable.
For example, set this property to PATH=newpath;%PATH%


Hope this helps,
Mat
Back to top
View user's profile
lyh



Joined: 24 May 2011
Posts: 2

PostPosted: Wed May 25, 2011 7:13 pm    Post subject: Reply with quote

mkcolg wrote:
Hi Lyh,

Try the following settings instead:

1) Linker | General | Additional Library Directories

Put the path to the CULA library directory

2) Linker | Input | Additional Dependencies

Put the name of the CULA library, i.e., libcula_pgfortran.lib

3) Debugging | Environment

Add the path to the CULA DLLs to the PATH environment variable.
For example, set this property to PATH=newpath;%PATH%


Hope this helps,
Mat



Thanks for your help
I had done according your suggestions,but it still have errors
1)Linker | General | Additional Library Directories
C:\Program Files\cula\lib

2) Linker | Input | Additional Dependencies
libcula_pgfortran.lib

3) Debugging | Environment(add"C:\Program Files\cula\bin"to the enviromrnt variable which is named"cula_bin_path_32")
%cula_bin_path_32%

Is there somthing wrong?
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group