PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Problem with PGI compiler

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
ajay.singh



Joined: 02 Sep 2010
Posts: 2

PostPosted: Tue Sep 07, 2010 5:12 am    Post subject: Problem with PGI compiler Reply with quote

Hello,

when i'm compiling CAMx using PGI compiler. I am getting the following error.
pgf90-Error-Unknown switch: -mcmodel=medium
make[1]: *** [Mod_src/camx_includes.o] Error 1
make[1]: Leaving directory `/home/cese/mayank/camx'
make: *** [pg_linux] Error 2

I am new user to pgi and CAMx.can anyone tell me the solution.Any help would be highly helpful.
I am using fedora13 and Intel i3 processor

with regard
Mayank
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Tue Sep 07, 2010 8:27 am    Post subject: Reply with quote

Hi,

Can you compile just a helloworld program? If yes, add a flag -mcmodel=medium. If no, I wonder if the installation is complete.

Hongyon
Back to top
View user's profile
ajay.singh



Joined: 02 Sep 2010
Posts: 2

PostPosted: Tue Sep 14, 2010 4:28 am    Post subject: Reply with quote

Thank you very much Hongyon for your reply. I have successfully compiled and run helloworld program. As I told I am totally new to this enviroment. Can you please tell me how to add flags in pgi compiler. Using terminal in fedora 13
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Tue Sep 14, 2010 3:08 pm    Post subject: Reply with quote

Hi Mayank,

My best guess is that your using the 32-bit compilers. "-mcmodel=medium" is a 64-bit only flag. What is the output of "pgfortran -V"?

If this is case then your options are to set your PATH environment variable to use the 64-bit compilers, or change CAMx's Makefile link so that it points to the 32-bit Makefile, "Makefile.32bit" instead of the default 64-bit Makefile, "Makefile.pg_64bit".

Hope this helps,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group