PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Loop unrolling (PGI 5.1 and 5.2: pgf77)
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
mkrech



Joined: 15 Oct 2004
Posts: 11

PostPosted: Tue May 31, 2005 4:40 am    Post subject: Reply with quote

Dear Mat,

I just learned that the compiler option -Msave makes the program run and yield
correct results for any optimization level. It seems as if there is a 'memory leak'
caused by one of the subroutines in the program if compiled for 64 bit opteron
machines.

Best regards,
Michael
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5815
Location: The Portland Group Inc.

PostPosted: Tue May 31, 2005 11:47 am    Post subject: Reply with quote

Hi Michael,

I'm glad you were able to get things to work correctly. Although I'm not entirely convinced that its a compiler bug, we're happy to look at it here to see if we can determine the root cause of the error. Please send a note to trs@pgroup.com and they'll give you instructions on how you can upload the code. Just give a brief explanation and let them know that you have been talking with me.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group