PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGF90-S-0038-Symbol problem

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
.zYs.



Joined: 11 Apr 2010
Posts: 21

PostPosted: Fri Apr 30, 2010 2:09 pm    Post subject: PGF90-S-0038-Symbol problem Reply with quote

Hi Mat

I just got a problem with compilation. The error msg is
PGF90-S-0038-Symbol, trils, has not been explicitly declared

I have no clue about trils. What is that?

Thanks!!!!

Yisen
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6120
Location: The Portland Group Inc.

PostPosted: Fri Apr 30, 2010 4:47 pm    Post subject: Reply with quote

Hi Yisen,

This error means that you have "implicit none" set and one of your variables, "trils", has not be defined. Search your source for the symbol, determine what it's type is, and then add a definition for it.

Hope this helps,
Mat
Back to top
View user's profile
.zYs.



Joined: 11 Apr 2010
Posts: 21

PostPosted: Fri Apr 30, 2010 7:12 pm    Post subject: Reply with quote

Yes !!

I have a typo there. Because the variable I define is in the upper case, I didnt realize what trils is. This is really stupid.

Wont bother you with such kind of question :)

Thanks Mat

Yisen
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group