PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

pgdbg fails on Mac OS X
Goto page Previous  1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
mkcolg



Joined: 30 Jun 2004
Posts: 5815
Location: The Portland Group Inc.

PostPosted: Tue Feb 14, 2012 10:41 am    Post subject: Reply with quote

Hi khea_actual1,

Quote:
So.... Basically I won't be able to debug my code with the PGI debugger we bought on OS X Lion without re-buying a license to upgrade it?
Contact PGI Sales (sales@pgroup.com) to get a quote. Typically, you only need to pay the cost to bring your subscription current. Note that Lion was not officially supported till the 2011 release.

Quote:
Can PGI code be debugged with gdb?
Yes, but gdb doesn't know Fortran so it may have trouble listing some symbols. It's also my understanding that you need to have root privileges in order to run gdb on Lion.

- Mat
Back to top
View user's profile
khea_actua1



Joined: 06 Nov 2008
Posts: 42
Location: Carleton University

PostPosted: Thu Nov 29, 2012 8:03 am    Post subject: Same problems with PGI 12.9 and Mountain Lion (OSX 10.8.2) Reply with quote

Hi,

Since that last posting, I have updated my subscription and have upgraded to 12.9, but have also upgraded the OS to Mountain Lion.

I still see the same error when I try to debug,

Code:

matt@pontus:run.generic$ pgdebug ctm_mod.Abs
PGDBG 12.9-0 x86-64 (Workstation, 16 Process)
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2012, STMicroelectronics, Inc. All Rights Reserved.
Loaded: /Users/matt/aurams/trunk/versions/kappa12/runs/run.generic/ctm_mod.Abs

pgdbg> run
pserv_init: task_for_pid failed:  (os/kern) failure
- recv: message receive: Undefined error: 0
- recv: message receive: Undefined error: 0
- recv: message receive: Connection reset by peer
- send: message send: Broken pipe
ERROR: CANNOT LOAD /Users/matt/aurams/trunk/versions/kappa12/runs/run.generic/ctm_mod.Abs


File permissions,
Code:

-rwxrwsr-x  1 root  procmod    22M 20 Sep 16:48 pgdebug
-rwxrwsr-x  1 root  procmod   133K 20 Sep 16:48 pgserv


Is there any way I can run the debugger on Mountain Lion?
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5815
Location: The Portland Group Inc.

PostPosted: Thu Nov 29, 2012 6:06 pm    Post subject: Reply with quote

The "task_for_pid" failure means that it is a problem with your privileges configuration.

It looks like your permissions are correct. Did you install the debugger on a local drive? Are you a member of the "procmod" group?

- Mat
Back to top
View user's profile
khea_actua1



Joined: 06 Nov 2008
Posts: 42
Location: Carleton University

PostPosted: Mon Dec 10, 2012 9:16 am    Post subject: Reply with quote

Hi Mat, sorry for my late reply.

The debugger is installed on a local drive, and I am in that group:

Code:

matt@pontus:run.generic$ dscl . -read /Groups/procmod GroupMembership
GroupMembership: root matt


After adding my self to it, I logged out and logged in, and still got the same error:

Code:

matt@pontus:run.generic$ pgdebug ctm_pre.Abs
PGDBG 12.9-0 x86-64 (Workstation, 16 Process)
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2012, STMicroelectronics, Inc. All Rights Reserved.
Loaded: /Users/matt/aurams/trunk/versions/kappa13/runs/run.generic/ctm_pre.Abs

pgdbg> run
pserv_init: task_for_pid failed:  (os/kern) failure
- recv: message receive: Undefined error: 0
- recv: message receive: Undefined error: 0
- recv: message receive: Undefined error: 0
- send: message send: Broken pipe
ERROR: CANNOT LOAD /Users/matt/aurams/trunk/versions/kappa13/runs/run.generic/ctm_pre.Abs.
Back to top
View user's profile
khea_actua1



Joined: 06 Nov 2008
Posts: 42
Location: Carleton University

PostPosted: Wed Jan 02, 2013 9:40 am    Post subject: Reply with quote

So the debugger just doesn't work on Mountain Lion? :(
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group