PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGDBG GUI and environment variables
Goto page Previous  1, 2, 3, 4
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Tue Mar 02, 2010 5:41 pm    Post subject: Reply with quote

Pierre-François

One possible cause of what you are seeing is if you are running the debugger with elevated privileges. This might occur if you are running the debugger using sudo or su, or if the file permissions for the debugger executable(s) have been changed so that they have the setuid or setgid bit set.

You could check the setuid/setgid issue by running

ls -l /opt/pgi/linux86-64/10.2/bin/pgd*

and checking for the letter 's' in the file permissions. There should only be rwx permissions for these files on Linux.

On Mac OSX the executable "pgdebug" is run using setgid "procmod" permissions, but this is not required, nor desirable, on Linux.

--Don
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group