PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Error in debugging the program in PGDBG

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
ajit.upadhyay



Joined: 10 Nov 2009
Posts: 2

PostPosted: Wed Nov 18, 2009 10:34 pm    Post subject: Error in debugging the program in PGDBG Reply with quote

Hi.......

I have installed pgi compiler under the /opt/pgi/ and mpich in /opt/pgi/linux86-64/9.0/mpi/mpich/
it is work fine at one process but when we debug on multi processes then these problems occur ........

When we compile the program than no problem -
pgCC -g -o mpi_allgather_3 mpi_allgather_3.cpp -lmpich

when we give the command to run and debug the program--
mpirun -dbg=pgdbg -np 5 /home/plasma/pgi_examples/mpi_allgather_3 &

then pgi compiler open but when we press the continue button than these problems occured .

PGDBG Program I/O-
execvp:No such file or Directory


pgdbg> libnss_files.so.2 loaded by ld-linux-x86-64.so.2.
libnss_compat.so.2 loaded by ld-linux-x86-64.so.2.
libnsl.so.1 loaded by ld-linux-x86-64.so.2.
libnss_nis.so.2 loaded by ld-linux-x86-64.so.2.

Warning!!!! The current implementation of PGDBG supports
the debugging MPI application with randomized loading by
duplicating symbol information for each process. If
PGDBG is consuming too much memory, you should consider
running:

sysctl -w kernel.randomize_va_space=0

ERROR: New Process (PID 25769, HOST plasma1) ATTACH FAILED.
ERROR: New Process (PID 25769, HOST plasma1) IGNORED.
ERROR: Cannot read value at address 0x73A6B0.
ERROR: Cannot read value at address 0x73A6B8.
ERROR: Cannot read value at address 0x73A6C0.
ERROR: New Process (PID 0, HOST unknown) IGNORED.
ERROR: Cannot read value at address 0x73A6C8.
ERROR: Cannot read value at address 0x73A6D0.
ERROR: Cannot read value at address 0x73A6D8.
ERROR: New Process (PID 0, HOST unknown) IGNORED.
ERROR: Cannot read value at address 0x73A6E0.
ERROR: Cannot read value at address 0x73A6E8.
ERROR: Cannot read value at address 0x73A6F0.
ERROR: New Process (PID 0, HOST unknown) IGNORED.
ERROR: Thread Running. Ignoring cont.
ERROR: Ignoring cont.



please help me
What should i do?

Thanks

-Rajeev
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Thu Nov 19, 2009 8:34 am    Post subject: Reply with quote

Hi Rajeev,

Is the home directory mounted on the remote nodes? The error seems to indicate the PGDBG can't find your program.

- Mat
Back to top
View user's profile
ajit.upadhyay



Joined: 10 Nov 2009
Posts: 2

PostPosted: Thu Nov 19, 2009 9:22 pm    Post subject: Reply with quote

hi Mat!
Thanks for reply!
I am using standalone HPxw8600 workstation with two intel quad core processors (total 8 cores), it is not a cluster.

Initially, PGI MPICH was conflicting with my standard MPICH2, which was removed to compile the code in PGI MPICH.

now, the debugger loads on MPIRUN, but it sets the first breakpoint at MPI_Init and after clicking continue, it gives the aforesaid error.

(there is no question of remote nodes or remote mounting of /home)

PGDBG is not able to attach processes to other processors.

please help

thanks,
rajeev
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group