PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Fail to run license manager?

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
QOS



Joined: 01 May 2009
Posts: 7

PostPosted: Sat Jun 20, 2009 4:39 pm    Post subject: Fail to run license manager? Reply with quote

I reinstall the system to CentOS5.2 and the reinstall the PGI7.2. It is quite smooth to install the comipler. I also start the 'lmgrd.rc start'

but when I use it to compile my test program, it shows
---------------------------------------------------------------------------
pgi-cc-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-cc-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-cc-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-cc-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-cc-lin64: LICENSE MANAGER PROBLEM: Cannot connect to license server system.
The license server manager (lmgrd) has not been started yet,
the wrong port@host or license file is being used, or the
port or hostname in the license file has been changed.
Feature: pgi-cc-lin64
Server name: x.y.w.z
License path: /opt/pgi/license.dat:
FLEXnet Licensing error:-15,570. System Error: 115 "Operation now in progress"
For further information, refer to the FLEXnet Licensing documentation,
available at "www.macrovision.com".

----------------------------------------------------------------------
At the beginning, I have the hostname set as 'linux' in the webpage of PGI whne downloading the premanent license, but I find that it is not consistent with my ip address so I recreate a license key (the hostid is the same, I am sure).

Moreover, when I run "lmgrd.rc stop", it shows

lmutil - Copyright (c) 1989-2007 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
Shutdown failed: Cannot connect to license server system. (-15,570:115 "Operation now in progress")

and I try to run lmgrd directly, it shows

18:44:20 (lmgrd) -----------------------------------------------
18:44:20 (lmgrd) Please Note:
18:44:20 (lmgrd)
18:44:20 (lmgrd) This log is intended for debug purposes only.
18:44:20 (lmgrd) In order to capture accurate license
18:44:20 (lmgrd) usage data into an organized repository,
18:44:20 (lmgrd) please enable report logging. Use Macrovision's
18:44:20 (lmgrd) software license administration solution,
18:44:20 (lmgrd) FLEXnet Manager, to readily gain visibility
18:44:20 (lmgrd) into license usage data and to create
18:44:20 (lmgrd) insightful reports on critical information like
18:44:20 (lmgrd) license availability and usage. FLEXnet Manager
18:44:20 (lmgrd) can be fully automated to run these reports on
18:44:20 (lmgrd) schedule and can be used to track license
18:44:20 (lmgrd) servers and usage across a heterogeneous
18:44:20 (lmgrd) network of servers including Windows NT, Linux
18:44:20 (lmgrd) and UNIX. Contact Macrovision at
18:44:20 (lmgrd) www.macrovision.com for more details on how to
18:44:20 (lmgrd) obtain an evaluation copy of FLEXnet Manager
18:44:20 (lmgrd) for your enterprise.
18:44:20 (lmgrd)
18:44:20 (lmgrd) -----------------------------------------------
18:44:20 (lmgrd)
18:44:20 (lmgrd)
18:44:20 (lmgrd) The license server manager (lmgrd) running as root:
18:44:20 (lmgrd) This is a potential security problem
18:44:20 (lmgrd) and is not recommended.
[root@139 tmp]# 18:44:20 (lmgrd) Failed to open the TCP port number in the license.


What's going on?
Back to top
View user's profile
QOS



Joined: 01 May 2009
Posts: 7

PostPosted: Sun Jun 21, 2009 9:55 am    Post subject: Reply with quote

I might found a solution. Now I turn the firewall off, and run lmgrd again, it show some information.

----------------------------------------------------------------------------------
11:51:34 (lmgrd) FLEXnet Licensing (v11.5.0.0 build 56285 x64_se9) started on x.y.z.w (linux) (6/21/2009)
11:51:34 (lmgrd) Copyright (c) 1988-2007 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
11:51:34 (lmgrd) US Patents 5,390,297 and 5,671,412.
11:51:34 (lmgrd) World Wide Web: http://www.macrovision.com
11:51:34 (lmgrd) License file(s): /opt/pgi/license.dat
11:51:34 (lmgrd) lmgrd tcp-port 27000
11:51:34 (lmgrd) Starting vendor daemons ...
11:51:34 (lmgrd) Started pgroupd (internet tcp_port 41893 pid 17755)
11:51:34 (pgroupd) FLEXnet Licensing version v11.5.0.0 build 56285 x64_se9
11:51:34 (pgroupd) Server started on x.y.z.w for:
11:51:34 (pgroupd) pgi72-workstation-complete (consisting of: pgi-hpf-lin64
11:51:34 (pgroupd) pgi-f95-lin64 pgi-f77-lin64 pgi-cc-lin64
11:51:34 (pgroupd) pgi-cpp-lin64 pgi-hpf-lin32 pgi-f95-lin32
11:51:34 (pgroupd) pgi-f77-lin32 pgi-cc-lin32 pgi-cpp-lin32
11:51:34 (pgroupd) pgi-f95-win32 pgi-f77-win32 pgi-cc-win32
11:51:34 (pgroupd) pgi-cpp-win32 pgi-prof pgi-dbg
11:51:34 (pgroupd) pgi-dbg-gui)
11:51:34 (pgroupd) pgi71-workstation-complete (consisting of: pghpf-linux86-64
11:51:34 (pgroupd) pgf90-linux86-64 pgf77-linux86-64 pgcc-linux86-64
11:51:34 (pgroupd) pgcpp-linux86-64 pghpf-linux86 pgf90-linux86
11:51:34 (pgroupd) pgf77-linux86 pgcc-linux86 pgcpp-linux86
11:51:34 (pgroupd) pgf90-win32 pgf77-win32 pgcc-win32
11:51:34 (pgroupd) pgcpp-win32 pgprof pgdbg
11:51:34 (pgroupd) pgdbg-gui pgdbg-linux86-64)
11:51:34 (pgroupd) EXTERNAL FILTERS are OFF
11:51:34 (lmgrd) pgroupd using TCP-port 41893

----------------------------------------------------------------------------------

So does it mean it is working good now? Why the TCP-port is 41893 instead of 27000?

After I start the lmgrd and verify the license, I turn the firewall on again. To compile some test program with PGI, it returns

11:54:10 (pgroupd) TCP_NODELAY NOT enabled
11:54:10 (pgroupd) OUT: "pgi72-workstation-complete" jay@x.y.z.w
11:54:10 (pgroupd) OUT: "pgi-cc-lin64" jay@x.y.z.w
11:54:10 (pgroupd) IN: "pgi72-workstation-complete" jay@x.y.z.w
11:54:10 (pgroupd) IN: "pgi-cc-lin64" jay@x.y.z.w

So everytime when doing compilation, it will so this message? Is it normal? WHY "TCP_NODELAY NOT enabled" ? Does it matter?

By the way, it seems that PGI only need to verify the license once (and I have to turn off the firewall), and later on, it no more connect to the remote server to verify the license during compilation, so I can turn the firewall on, right?
Back to top
View user's profile
jtull



Joined: 30 Jun 2004
Posts: 373

PostPosted: Mon Jun 22, 2009 9:57 am    Post subject: License problems Reply with quote

QOS,

Sorry you are having problems. With a firewall, users usually have to
assign a specific port both th elmgrd and pgroupd daemons, and then
tell the firewall to let them through those ports.

The hostname is usually the output of

lmutil lmhostid -hostname

while the hostid is the output of

lmutil lmhostid

This extracts the hostname from /etc/hosts and the hostid is the
MAC address of eth0.

Often, with DNS, the /etc/hosts file is only used with the hostname
'localhost' or 'localhost.localdomain'. In this case, try locahost or
'localhost.localdomain'

Once you have determined the hostname (for example, 'foo'),
edit the license file by hand

SERVER foo 0123456789ab 27000
DAEMON pgroupd

should become

SERVER foo 0123456789ab 27000
DAEMON pgroupd PORT=7496

and tell the firewall to allow lmgrd through 27000,
and pgroupd through 7496.

We read the license on every execution, so you need
to keep the license server running.
Back to top
View user's profile
QOS



Joined: 01 May 2009
Posts: 7

PostPosted: Mon Jun 22, 2009 10:09 am    Post subject: Reply with quote

Thank you so much for your reply. I've already change the hostid in the license.dat manually. Well, I just quite confuse for one thing. For the very first time when I use pgi to compile my source, it trying to connect and verify my lience remotely, at this time, I must turn off the firewall to make it work (just adding the port 27000 in the firewall doesn't work). And later on, by adding the port 27000 and let the firewall turn on, it works (forever)!?
Back to top
View user's profile
jtull



Joined: 30 Jun 2004
Posts: 373

PostPosted: Mon Jun 22, 2009 2:38 pm    Post subject: License problems Reply with quote

If the hostid changes, you must regenerate a new license online.
If the hostname changes, you can edit the license by hand.

I did not tell you what to do with the Firewall in a specific way,
because I do not know what Firewall you are using. In general,
Firewalls have a way to let daemons or processes through
designated ports. The lmgrd port shoudl be the same for all the
flexlm licenses you are running on the machine. The pgroupd daemon, and
the other daemons for other licensed software, should each have a
unique port number.

I believe your license PIN is 512176, a single user, node-locked license.
The compilers can only run on the same machine the license server
is running on.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group