PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Warning-CUDALIB is not set
Goto page Previous  1, 2
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
mkcolg



Joined: 30 Jun 2004
Posts: 6215
Location: The Portland Group Inc.

PostPosted: Fri Sep 17, 2010 2:11 pm    Post subject: Reply with quote

Hi jpell,

You should only see this message if you have not installed the NVIDA CUDA Toolkits that accompany the PGI installation and/or if you have added a sitenvrc file that sets CUDALIB.

If you have created sitenvrc file, please remove it since it is not longer needed.

Quote:
I installed the cuda libraries as instructed during installation

Can you double check this? (i.e. dir "C:\Program Files\PGI\win64\2010\cuda").

Thanks,
Mat
Back to top
View user's profile
jpell



Joined: 16 Sep 2010
Posts: 3

PostPosted: Wed Sep 22, 2010 1:44 pm    Post subject: Reply with quote

I've double checked. Here are the subfolders under that path.


C:\Program Files\PGI\win64\2010\cuda\2.3
C:\Program Files\PGI\win64\2010\cuda\2.3\bin
C:\Program Files\PGI\win64\2010\cuda\2.3\include
C:\Program Files\PGI\win64\2010\cuda\2.3\lib
C:\Program Files\PGI\win64\2010\cuda\2.3\open64


C:\Program Files\PGI\win64\2010\cuda\3.1
C:\Program Files\PGI\win64\2010\cuda\3.1\bin
C:\Program Files\PGI\win64\2010\cuda\3.1\include
C:\Program Files\PGI\win64\2010\cuda\3.1\lib
C:\Program Files\PGI\win64\2010\cuda\3.1\open64


Perhaps there is an issue with a PATH environment variable ?
Back to top
View user's profile
jpell



Joined: 16 Sep 2010
Posts: 3

PostPosted: Fri Sep 24, 2010 8:32 am    Post subject: Reply with quote

The problem is fixed.

I needed to:
Uninstall the entire program.
Then reboot.
Then do a reinstall.
Upon reinstalling I did not select "Install Cygwin".

There must have been a conflict between Cygwin and Windows on my system.

Now for some accelerator tests...
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group