PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

HPL 2.0 and pgi 8.0-3

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
bchang



Joined: 20 Jul 2005
Posts: 14

PostPosted: Sat Mar 28, 2009 3:16 pm    Post subject: HPL 2.0 and pgi 8.0-3 Reply with quote

hello, I'm building hpl 2.0 with pgi compiler suit running ACML 4.2
everything builds fine but when I run xhpl, xhpl does not fail but does not allocate memory for the xhpl process.
for example:
running problem size of 110000 on dual 64 gig memory nodes, I should be using about 38 Gig memory on each node.(this was the case with GCC)
when I try to run the xhpl with mvapich2 (built with pgi 8.0-3) the memory allocation is only 600MB.
however if the problem size is small say: 20000 it returns results.

Any hints is appreciated, here is the ldd output:
libacml.so => /opt/pgi/linux86-64/8.0-3/libso/libacml.so (0x00002b62ef188000)
libacml_mv.so => /opt/pgi/linux86-64/8.0-3/libso/libacml_mv.so (0x00002b62f3e62000)
/usr/local/ofed/mpi/pgi/mvapich2-1.0.3/lib/libmpich.so (0x00002b62f3fa9000)
librdmacm.so.1 => /usr/local/ofed/lib64/librdmacm.so.1 (0x00002b62f4358000)
libibverbs.so.1 => /usr/local/ofed/lib64/libibverbs.so.1 (0x00002b62f455d000)
libibumad.so.1 => /usr/local/ofed/lib64/libibumad.so.1 (0x00002b62f476a000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003527a00000)
librt.so.1 => /lib64/librt.so.1 (0x0000003528a00000)
libm.so.6 => /lib64/libm.so.6 (0x0000003527600000)
libc.so.6 => /lib64/libc.so.6 (0x0000003526e00000)
libpgftnrtl.so => /opt/pgi/linux86-64/8.0-3/libso/libpgftnrtl.so (0x00002b62f4971000)
libpgc.so => /opt/pgi/linux86-64/8.0-3/libso/libpgc.so (0x00002b62f4a9f000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000003527200000)
libibcommon.so.1 => /usr/local/ofed/lib64/libibcommon.so.1 (0x00002b62f4be6000)
/lib64/ld-linux-x86-64.so.2 (0x0000003526a00000)
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Mon Mar 30, 2009 2:46 pm    Post subject: Reply with quote

Hi Brady,

Can you please send your Make.arch and HPL.dat files to trs@pgroup.com?

I'm not an expert with HPL so will need to try an recreate the error here. Though, one thing to try would be to add "-Mlarge_arrays" to the compilation.

- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group