PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

How to debug openMP

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
CasperK



Joined: 12 Dec 2006
Posts: 33

PostPosted: Fri Mar 06, 2009 7:28 am    Post subject: How to debug openMP Reply with quote

Hi.

I am currently testing PGI Visual Fortran and have a question on debugging openMP code. It seems when i enter an OpenMP region the debugger only follow one thread, ie. when i step through the artificial example below the loop ends when i=4. How do I debug the threads running the remaining i's?

Regards,

Casper Kirkegaard


!$OMP PARALLEL PRIVATE(I,X) NUM_THREADS(8)
!$OMP DO
DO I=1,32
X=X+I
ENDDO
!$OMP END DO
!$OMP END PARALLEL
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6122
Location: The Portland Group Inc.

PostPosted: Mon Mar 09, 2009 8:53 am    Post subject: Reply with quote

Hi Casper,

Support for OpenMP and MPI debugging from within the PVF Visual Studio IDE will be available in the 8.1 release.

If you have access to the PGI Windows Workstation, Sever, or CDK product, you can build your application within PVF, and then from a DOS or Cygwin command line, run it in our stand-alone debugger, PGDBG. PGDBG does support OpenMP and MPI debugging.

- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group