PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

MM5 performance on AMD64 Opteron
Goto page Previous  1, 2, 3, 4
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
mkcolg



Joined: 30 Jun 2004
Posts: 6215
Location: The Portland Group Inc.

PostPosted: Mon Feb 27, 2006 11:51 am    Post subject: Reply with quote

Hi Victor,

The problem is that they use gcc to link, but the PGI runtimes are not being included on the link line. I tried changing the "CtoFLibraries" in the LINUX file to include these libraries, but for some reason, Configure just ignores them.

Instead, either edit the Makefile's "CTOFLIBS" variable to include the following libraries, or simply pass them via the command line:
Code:
make Everything CTOFLIBS=" -L/usr/pgi/linux86/6.0/lib -lpgf90  -lpgf90_rpm1  -lpgf902 -lpgf90rtl -lpgftnrtl -lpgc -lg2c -lgcc -lm" >& make-output &


Please change the PGI library path if different. I was able to successfully compile all objects using pgf90 and gcc when I added the correct runtime libraries.

Hope this helps,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group