PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

assembler error: no such instruction
Goto page 1, 2  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
Sanik



Joined: 26 Jan 2006
Posts: 22
Location: Russia

PostPosted: Fri Feb 04, 2011 12:38 am    Post subject: assembler error: no such instruction Reply with quote

Hi,


I am trying to compile an application on Windows with PGI 11.1 using -fastsse option. But I am getting error messages from assembler:

C:\DOCUME~1\..\LOCALS~1\Temp\3\pgcc3bRaebbp8O_1uR.s: Assembler messages:
C:\DOCUME~1\..\LOCALS~1\Temp\3\pgcc3bRaebbp8O_1uR.s:516: Error: no such instruction: `pcmpeqq %xmm3,%xmm0'
C:\DOCUME~1\..\LOCALS~1\Temp\3\pgcc3bRaebbp8O_1uR.s:524: Error: no such instruction: `pcmpeqq %xmm3,%xmm0'
C:\DOCUME~1\..\LOCALS~1\Temp\3\pgcc3bRaebbp8O_1uR.s:532: Error: no such instruction: `pcmpeqq %xmm3,%xmm0'


If it were Linux it would be a problem with binutils. What about Windows?
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Mon Feb 07, 2011 6:22 pm    Post subject: Reply with quote

Hi Sanik,

PGI provides it's own assembler on Windows. The current one hasn't been updated to include SSE4 yet. We do have an updated version, that also includes support for AVX, available as part of the 11.2 release. It will not be the default assembler so you will need to manually replace "as64.exe" with "as64new.exe" (or "as32.exe" with "as632new.exe") or pass to the compiler "AS=as64new.exe".

Hope this helps,
Mat
Back to top
View user's profile
Sanik



Joined: 26 Jan 2006
Posts: 22
Location: Russia

PostPosted: Mon Feb 07, 2011 10:03 pm    Post subject: Reply with quote

Thank you.
Back to top
View user's profile
esajz24



Joined: 27 Feb 2013
Posts: 2

PostPosted: Tue Mar 05, 2013 4:31 pm    Post subject: Same errors, but on linux Reply with quote

Hi,

I'm getting those same "Error: no such instruction" messages.

Unlike Sanik, I am on a linux machine. I'm not very experienced with linux, so I'm unsure of how to solve the problem, even with the binutils hint.

Your help is appreciated!

Thanks!
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Tue Mar 05, 2013 5:05 pm    Post subject: Reply with quote

Hi esajz24,

Most likely you're on a system that supports AVX but the OS and assembler is a little older so doesn't recognize these new instructions. The two solutions are to either have PGI target and older processors (such as -tp=penryn-64 (Intel) or -tp=barcelona=64 (AMD), or -tp=px-64 (generic 64-bit)), or update your binutils (which at the assembler is part). You can find the latest binuilts at http://ftp.gnu.org/gnu/binutils/.

Though to be sure, can you please post an example of the unknown instruction and the output from "pgcpud"?

- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group