PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

undefined reference to pghpf_sect1 and pghpf_sect2

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
none38383



Joined: 02 Apr 2005
Posts: 3

PostPosted: Mon May 09, 2005 10:13 am    Post subject: undefined reference to pghpf_sect1 and pghpf_sect2 Reply with quote

PGI Users,

I'm try to build a version of ls-dyna using a custom routine. I have the libraries from ls-dyna which the vendor said were built with PGI for x86-64. When I link my object file with their libraries, I get a bunch of "undefined reference to `pghpf_sect1'" errors. Where is pghpf_sect1 and pghpf_sect2? Why do I see these errors? I'm using pghpf 6.0-1 64-bit target on x86-64 Linux 2.6.9.

Kevin
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Mon May 09, 2005 10:48 am    Post subject: Reply with quote

Hi Kevin,

You'll need to build your routine with pgf90 since LS-DYNA was built with pgf90. pghpf uses some internal symbols in objects which are not present when compiling with pgf90.

- Mat
Back to top
View user's profile
none38383



Joined: 02 Apr 2005
Posts: 3

PostPosted: Tue May 10, 2005 4:58 am    Post subject: Reply with quote

Mat,

I tried to reply earlier, but it didn't get posted. Anyways, I've already tried compiling with pgf90, but I get the same errors. I'm using pgf90 v6.0-1 while the guys at LSTC tell me that the LS-DYNA libraries were built with v5.2-4. Could this be the root of the problem? Maybe there are some options I can pass to pgf90 so that it can find pghpf_sect1?

Kevin
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Tue May 10, 2005 1:29 pm    Post subject: Reply with quote

Hi Kevin,

Yes, 5.2-4 vs 6.0 is the problem. I talked to our application engineer who works with LSTC, and she said that you'll need to use 5.2-4 until LSTC comes out with a version for use with 6.0.

The good news is that your 6.0 license will work with 5.2. If you don't have 5.2-4 already installed, you can download 5.2-4 from http://www.pgroup.com/support/download_archive.php. Both versions of the compiler can be installed under the same base PGI directory and you can swtich between the two by passing the "-V5.2", or "-V6.0" flag to the compiler.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group