PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

PGI Visual Fortran 2005 Accelerator on nVidia Quadro NVS 290
Goto page 1, 2  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
X_FRANK



Joined: 30 Mar 2010
Posts: 9

PostPosted: Sat Apr 03, 2010 5:20 pm    Post subject: PGI Visual Fortran 2005 Accelerator on nVidia Quadro NVS 290 Reply with quote

Hi


Recently, i tried to test PGI Visual Fortran Accelerator on my workstation. Compilation of a very simple code achieved very well, but when i ran the program, an un-managed runtime error occured.

NB : my GPU is a nVidia Quadro NVS 290, and i selected "Compute Capability 1.1" in compiler properties.

I known that my card is CUDA - enabled, as template applications of the CUDA Toolkit from nVidia ran very well on it. Was Quadro NVS 290 tested by engineers of Portland Group ???

Thank you very much.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Mon Apr 05, 2010 12:59 pm    Post subject: Reply with quote

Hi X_FRANK,

If your device supports CUDA, then we support the device. Hence, I suspect something else is going on. Can you please post the error message your getting?

Note that we do use CUDA version 2.3 hence your NVIDIA CUDA driver also needs to support CUDA 2.3. I have seen failures due to older drivers.

- Mat
Back to top
View user's profile
X_FRANK



Joined: 30 Mar 2010
Posts: 9

PostPosted: Mon Apr 05, 2010 2:07 pm    Post subject: answer Reply with quote

Thank you for your help

I will check driver version tomorrow. I think i actualised it very recently, but i have to be sure of that.

However, the problem is that i can see no error message at all. Error is not managed, and a debugging with visual studio is proposed. I will send you tomorrow error message the debugger display. An access violation if i remember well.

NB : the file nvcudart.dll was missing, according to compiled software. The file cudart.dll was present on my drive : i copied it in the release folder and modified it's name. At this point, runtime error occured.


X Frank
Back to top
View user's profile
X_FRANK



Joined: 30 Mar 2010
Posts: 9

PostPosted: Tue Apr 06, 2010 12:38 am    Post subject: Error message from debugger Reply with quote

Hi

The debugger's error message is (translated from french language) :

Not managed error at 0x00b390fe in gpgpu.exe : 0xC0000005: Acces violation during reading at 0x00000000000000a8.

My NVCUDA.DLL driver version is : 3.0.1

Thank you



X Frank
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Tue Apr 06, 2010 3:50 pm    Post subject: Reply with quote

Quote:
NB : the file nvcudart.dll was missing, according to compiled software.
This error occurs when you mix CUDA Fortran (-Mcuda) with the PGI Accelerator Model (-ta=nvidia). While we will support mixing the two as some point, currently they should not be used together. Selecting one or the other will most likely fix your access violation.

Hope this helps,
- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group