PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGDBG GUI and environment variables
Goto page Previous  1, 2, 3, 4  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Fri Jan 22, 2010 5:57 am    Post subject: Reply with quote

Hello Mat,

Well, thanks for the hard work.
There is no such thing in my .bashrc. I also checked in the /etc/bashrc but it doesn't seem like there is an exit on non-interactiveness nor a different LD_LIBRARY_PATH set in that case.
Sorry - it could have been a solution!

Pierre-François
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 5952
Location: The Portland Group Inc.

PostPosted: Fri Jan 22, 2010 12:20 pm    Post subject: Reply with quote

Hi Pierre-François,

Can you please send your ".bashrc" to PGI Customer Service (trs@pgroup.com) and ask them to send it to me? Maybe we can then recreate the problem here.

Thanks,
Mat
Back to top
View user's profile
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Mon Jan 25, 2010 6:46 am    Post subject: Reply with quote

Mat,
Alright, I'll do that, although I doubt you can recreate the exact same environment configuration.
Thank you very much for your help anyway!

Cheers,
Pierre-François
Back to top
View user's profile
donb



Joined: 20 Jul 2004
Posts: 88
Location: The Portland Group, Inc.

PostPosted: Wed Jan 27, 2010 12:52 pm    Post subject: Reply with quote

Hi Pierre-François,

As a workaround you could try setting LD_LIBRARY_PATH in a .pgdbgrc file.

In the .pgdbgrc file you would use the setenv command, for example:

setenv LD_LIBRARY_PATH /lib:/usr/lib:/home/me/lib:/foo/bar/lib

The .pgdbgrc file can go in your home directory, in which case it will affect all PGDBG sessions for that user, or in the 'current directory' where you invoke pgdbg, in which case it will only affect sessions invoked in that directory.

Obviously this is not a final solution but perhaps it can help you make progress.
--Don
Back to top
View user's profile
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Fri Jan 29, 2010 6:44 am    Post subject: Reply with quote

Hi Don,
Well, thanks for the workaround. It works fine.
Could you keep me posted with a possible explanation on why the debbuger won't take into account my LD_LIBRARY_PATH?
Thanks!
Cheers,
Pierre-François
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group