PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

PGC-S-0040-Illegal use of symbol (installation problem?)

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
boukeB



Joined: 06 Apr 2005
Posts: 5

PostPosted: Wed Apr 06, 2005 5:01 am    Post subject: PGC-S-0040-Illegal use of symbol (installation problem?) Reply with quote

Hi,

I just installed the compiler, and i get an error when compiling the usual 'hello world' which doesn't mean too much to me. could you please enlighten me on what i did wrong?

~/test/compiler_tests> pgcc -o hello hello.c
PGC-S-0040-Illegal use of symbol, __SSIZE_T_TYPE (/apps/share/pgi-6.0/linux86-64/6.0/include/bits/types.h: 184)
PGC/x86-64 Linux/x86-64 6.0-1: compilation completed with severe errors

thank you.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6218
Location: The Portland Group Inc.

PostPosted: Wed Apr 06, 2005 8:30 am    Post subject: Reply with quote

Hello,

It does appear to be an install problem. What OS are you using? Also, what's the output from the commands "uname -a" and "/lib/libc.so.6"?

Thanks,
Mat
Back to top
View user's profile
boukeB



Joined: 06 Apr 2005
Posts: 5

PostPosted: Thu Apr 07, 2005 3:53 am    Post subject: Reply with quote

Thank you very much for your response. /lib/libc.so.6 gives output which indeed suggests someone should first look at our linux installation.

Sorry to have bothered you.
Back to top
View user's profile
boukeB



Joined: 06 Apr 2005
Posts: 5

PostPosted: Fri Apr 08, 2005 12:32 am    Post subject: Reply with quote

the 'PGC-S-0040-Illegal use of symbol' error went away after renaming the types.h file, then manually adjusting the localrc files made everything work as i want. the system is a dual opteron, running a 64 bit kernel, and Debian GNU/Linux as distribution.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group