PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGDBG GUI and environment variables
Goto page 1, 2, 3, 4  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Wed Jan 06, 2010 7:32 am    Post subject: PGDBG GUI and environment variables Reply with quote

Dear all,
Just a quick question : when running the Debugger in GUI mode, my environment variables are reset to somewhat basic values - e.g., LD_LIBRARY_PATH is reset to PGHPF lib path.
Question : how do I tell the debugger to load my user's environment variables rather than its own values?
Sorry if this question is either basic or already answered -didn't find it on the forums.

Many thanks to all in advance.

Pierre-François
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Wed Jan 06, 2010 11:40 am    Post subject: Reply with quote

Hi Pierre-François,

PGDBG will inherit the user's environment. So setting LD_LIBRARY_PATH before launching the debugger should include the correct shared library directories.

If setting LD_LIBRARY_PATH in the environment is not possible, the user can use the "setenv" command in the command window. For example "setenv LD_LIBRARY_PATH /path/to/lib1:/path/to/lib2:/path/to/lib3". "setenv LD_LIBRARY_PATH" will display the value of LD_LIBRARY_PATH.

Hope this helps,
Mat
Back to top
View user's profile
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Thu Jan 07, 2010 2:04 am    Post subject: Reply with quote

Mat,
Well, thank you for your answer.
However - and I guess that's an issue, PGDBG won't inherit my environment at all. Actually it seems to inherit every single variable environment (I checked PATH as an example) except for LD_LIBRARY_PATH.
How come?
Best regards,
Pierre-François
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Thu Jan 07, 2010 10:36 am    Post subject: Reply with quote

How are you launching PGDBG? (From the command line, a script, or from the OS start menu).

Which OS? (I've been assuming you're running Linux).

- Mat
Back to top
View user's profile
PFR



Joined: 23 Dec 2009
Posts: 12

PostPosted: Mon Jan 11, 2010 12:49 am    Post subject: Reply with quote

Dear Mat,
I'm running PGDBG from the command line on a Linux RedHat 5, 64 bits box using the command "pgdbg".

Pierre-François
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group