PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Missing pgi_cuda_runtime.h

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
analucia



Joined: 09 Dec 2009
Posts: 1

PostPosted: Wed Dec 09, 2009 8:44 am    Post subject: Missing pgi_cuda_runtime.h Reply with quote

Hi,

I've just installed the 10.0 trial version, using the already installed CUDA version (i.e., answering "no" to the CUDA install question). I have edited the sitenvrc file accordingly, but the compilation gets stuck because it does not find the "pgi_cuda_runtime.h". Which is, indeed, nowhere to be found.

If I copy the cuda_runtime.h from the original CUDA installation inside the /tmp/ directory, and rename it as pgi_cuda_runtime.h, the compilation is successful.

My question is - has anybody seen a similar problem? Also, are there any differences between pgi_cuda_runtime.h and cuda_runtime.h? If so, where can I find the file, and where is it supposed to be installed by the PGI installer?

Thanks!
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6206
Location: The Portland Group Inc.

PostPosted: Wed Dec 09, 2009 10:16 am    Post subject: Reply with quote

Hi analucia,

The "pgi_cuda_runtime.h" is included with the CUDA installation that ships with the compilers. You will need to reinstall 10.0 with the PGI CUDA installation.

Hope this helps,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group