PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

PGI 2010 and RedHat compatibility

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
Tuan



Joined: 11 Jun 2009
Posts: 233

PostPosted: Thu Nov 26, 2009 7:18 am    Post subject: PGI 2010 and RedHat compatibility Reply with quote

Based on the installation guide, Enterprise Linux Client release 5.4 is not in the list of supported OSs, and I also got compiling error with GCC 4.3.3.

Could any one confirm whether PGI 2010 is compatible with Redhat Enterprise 5.4 or how to work around this problem?

Errors :
Code:
/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/x86_64-unknown-linux-gnu/bits/c++config.h(233): error: expected a "{"

/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/bits/cpp_type_traits.h(74): error: expected a "{"

/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/bits/cpp_type_traits.h(81): error: expected a "{"

/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/bits/cpp_type_traits.h(308): error: name followed by "::" must be a class or namespace name

/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/bits/cpp_type_traits.h(308): error: too many arguments for class template "<error>::__is_normal_iterator"

/usr/local/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.3.4/../../../../include/c++/4.3.4/bits/cpp_type_traits.h(308): error: name followed by "::" must be a class or namespace name
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Thu Nov 26, 2009 9:49 am    Post subject: Reply with quote

Hi Tuan,

The NVCC compiler uses the gcc front end so need to know the gcc version. In 9.0, you would need to set this in the sitenvrc file if not the default (See http://www.pgroup.com/userforum/viewtopic.php?t=1488).

In 10.0, the PGI installer will auto-detect the gcc version so the correct version is passed to nvcc. So on this new OS, either our installer is not recognizing the gcc version, or worse, nvcc has a new incompatability.

First, try adding a sitenvrc file with the line "set GCCVERSION=40301;".

I'll investigate further once our office opens again on Monday (We're currently closed for the US Thanksgiving holiday).

- Mat
Back to top
View user's profile
Tuan



Joined: 11 Jun 2009
Posts: 233

PostPosted: Mon Feb 15, 2010 12:46 pm    Post subject: Reply with quote

Hi Mat,
Could you please double check the issue, one of our machine with RH installed still has the problem with PGI 10.2. The machine has gcc 4-3-4 and 4-4-0, with the former one default.

Tuan
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group