PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Error while compiling a program

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
hhegab



Joined: 28 Jan 2005
Posts: 14

PostPosted: Sun Mar 06, 2005 8:46 am    Post subject: Error while compiling a program Reply with quote

Peace!

I have been trying to compile a program with pgf77 and at the end of the compilation process I had the following error:
========================================================================
/usr/bin/ld: /crtbegin.o: No such file: No such file or directory
pgf77-Fatal-linker completed with exit code 1

make: *** [FeynHiggsFast.exe] Error 2
[hatim@hatim fhf15]$
=======================================================================
What is crtbegin.o? and what does it mean in general?
I am not good at programming, sorry!

hhegab
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6120
Location: The Portland Group Inc.

PostPosted: Mon Mar 07, 2005 10:23 am    Post subject: Reply with quote

Hi hhegab,

This is an installation problem. crtbegin.o is a system dependent object file that is needed for the operating system to load your file at the start of execution. crtbegin.o is part of your GCC installation and can change locations depending upon which system your on. During the installation of your compilers, the installer runs a script to determine where this and a few other files are located. So either you forgot to run the installation or your using a newer OS and the installer failed to recognize your system.

If you are on a Fedora Core 3 or RHEL 4.0, you'll need to download our Fedora Core 3 patch (ftp://ftp.pgroup.com/x86/linux86-patches/fedora3_patch.tar.gz). Unzip and untar this file in your base PGI directory and then re-run the install script.

Hope this helps,
Mat
Back to top
View user's profile
hhegab



Joined: 28 Jan 2005
Posts: 14

PostPosted: Tue Mar 08, 2005 3:54 am    Post subject: Thakn you very much Reply with quote

It worked fine!
Thank you very much for the help

hhegab

PS.
I think a note should be added in the home page of the main site.
Back to top
View user's profile
hhegab



Joined: 28 Jan 2005
Posts: 14

PostPosted: Tue Mar 08, 2005 4:47 am    Post subject: Another error Reply with quote

Hi,
I have the folllowing error when I try to compile a package I have
==========================================================================
-fomit-frame-pointer -Wall -DUNDERSCORE=1" -f ../../makefile.fe ../../build/MFeynHiggs
gmake[1]: Entering directory `/home/mborn/codes/fhmain/build/fe'
CC=../../build/fcc mcc -o ../../build/MFeynHiggs -O3 -fomit-frame-pointer -Wall -DUNDERSCORE=1 MFeynHiggs.tm ../../build/libFH.a
/bin/sh: mcc: command not found
gmake[1]: *** [../../build/MFeynHiggs] Error 127
gmake[1]: Leaving directory `/home/mborn/codes/fhmain/build/fe'
gmake: *** [build/MFeynHiggs] Error 2
[mborn@hatim fhmain]$
==========================================================================

What does it mean this time?
I have installed PGI as you described in the previous answer you posted and compiled the first package correctly, but in the file I downloaded I read in the READ_ME file that some files are to be replaced which I did not do, since I could compile the first packacge.
Could this be the cause of the problems I have while compiling the second package?

hhegab
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group