PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

PGF90-F-0000-Internal compiler error. Errors in Lowering 2
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Wed Aug 05, 2009 8:21 am    Post subject: Reply with quote

Hi Yus,

It doesn't look like the fix will be make into this weeks 9.0-3 release. Hopefully by 9.0-4 in September.

- Mat
Back to top
View user's profile
yus



Joined: 06 Oct 2008
Posts: 18

PostPosted: Wed Aug 05, 2009 3:14 pm    Post subject: Reply with quote

Hi Mat,

Thanks for the news.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Fri Aug 07, 2009 9:38 am    Post subject: Reply with quote

Hi yus,

The engineer who is looking at TRP#15998 sent me this update.

Quote:

Isolated the errors to two calls to mpi_type_create_indexed_block()
in Halos_Numbering.F90:create_global_to_universal_numbering_order_general().
In each case, the compiler bug is with processing the 3rd argument, an array
expression that corresponds to an adjustable array formal argument:

call mpi_type_create_indexed_block(halo_send_count(halo, i), 1, &
& halo_sends(halo, i) - lbound(halo%gnn_to_unn, 1), & <<<-- BUG
& getpinteger(), send_types(i), ierr)

and

call mpi_type_create_indexed_block(halo_receive_count(halo, i), 1, &
& halo_receives(halo, i) - lbound(halo%gnn_to_unn, 1), & <<<-- BUG
& getpinteger(), receive_types(i), ierr)

A workaround is to use a temp for the lbound expression in the third
argument, e.g.,


- Mat
Back to top
View user's profile
yus



Joined: 06 Oct 2008
Posts: 18

PostPosted: Mon Sep 21, 2009 5:39 am    Post subject: Reply with quote

Hi Mat,

Is this problem fixed in the new release?

Thanks.

yus
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6208
Location: The Portland Group Inc.

PostPosted: Mon Sep 21, 2009 9:00 am    Post subject: Reply with quote

Hi yus,

Yes, TPR#15998 is fixed as of the 9.0-4 release.

- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group