PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Version 6.1 and Glibc 2.6

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
Tom B.



Joined: 20 Jan 2009
Posts: 3

PostPosted: Thu Jan 22, 2009 10:36 am    Post subject: Version 6.1 and Glibc 2.6 Reply with quote

I just attempted to install version 6.1 of Workstation pgf77 for Linux on a Fedora Core 7 system. I got the following error during installation

ERROR: unknown glibc version (2.6).

I can execute pgf77 but many flags are not recognized (such as -v, -V, etc.). I assume that is because of the glibc problem.

Is there any way around the problem short of upgrading pgf77 or downgrading my host OS?

Thanks.
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6119
Location: The Portland Group Inc.

PostPosted: Thu Jan 22, 2009 11:10 am    Post subject: Reply with quote

Hi Tom,

There are two scripts called 'makelocalrc' found in the 32-bit and 64-bit bin directories that check which glibc is install. This check is necessary to ensure the correct header files and PGI C libraries are installed on your system. Since glibc 2.6 was released after PGI 6.1, this script does not contain an entry for 2.6. If you manually add a case to both files, using the same values as 2.3, and then rerun the 'install' script, the compilers should install.

While we have not heard of any issues with users installing 6.1 on Fedora 7, it is not officially supported. For a list supported OS please see: http://www.pgroup.com/support/install.htm#release_info

- Mat
Back to top
View user's profile
Tom B.



Joined: 20 Jan 2009
Posts: 3

PostPosted: Thu Jan 22, 2009 1:44 pm    Post subject: Reply with quote

Thanks, Mat, I'll try that.
Back to top
View user's profile
Tom B.



Joined: 20 Jan 2009
Posts: 3

PostPosted: Fri Jan 23, 2009 6:06 am    Post subject: Reply with quote

I did as Mat suggested and now all the flags work and I anticipate no more problems.

Thank you Mat!
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group