PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

License manager problem

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation
View previous topic :: View next topic  
Author Message
andreasm



Joined: 09 Mar 2006
Posts: 8

PostPosted: Thu Nov 20, 2008 9:25 am    Post subject: License manager problem Reply with quote

Hi,

I installed the pgi compiler version 7.2-5 on my laptop. I was using 64 bit installation. It seems to work but the license manager gives the following error when I try to compile a fortran program:

pgi-f95-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-f95-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-f95-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-f95-lin64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-f95-lin64: LICENSE MANAGER PROBLEM: License server machine is down or not responding.
See the system adminstrator about starting the license server system, or
make sure you're referring to the right host (see LM_LICENSE_FILE).
Feature: pgi-f95-lin64
Hostname: aitken
License path: /usr/local/pgi/license.dat:
FLEXnet Licensing error:-96,7. System Error: 2 "No such file or directory"
For further information, refer to the FLEXnet Licensing documentation,
available at "www.macrovision.com".

What is wrong here? The license file is in place in the directory /usr/local/pgi
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6123
Location: The Portland Group Inc.

PostPosted: Fri Nov 21, 2008 11:44 am    Post subject: Reply with quote

Hi andreasm,

It doesn't appear that your license manager had been started. To start the license server run '<pgi dir>/linux86-64/7.2-5/bin/lmgrd.rc start'. If there is still a problem, try running the license manager directly ('lmgrd') or view the log files (typically found in /var/log/lmgrd) to determine the error.

Best Regards,
Mat
Back to top
View user's profile
andreasm



Joined: 09 Mar 2006
Posts: 8

PostPosted: Fri Nov 21, 2008 1:02 pm    Post subject: Reply with quote

mkcolg,

thanks for your reply. I tried what you suggested. I started

/usr/local/pgi/linux86-64/7.2-5/bin/lmgrd.rc start

manually but this did not give any more information did not produce any error. However the problem is still the same.
The I tried lmgrd as a user which stopped and gave the following error:

20:59:09 (lmgrd) Unknown host: aitken
20:59:09 (lmgrd) EXITING DUE TO SIGNAL 33 Exit reason 1

BTW aitken is the name of my machine in /etc/conf.d/hostname
I do not have a directory /var/log/lmgrd
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6123
Location: The Portland Group Inc.

PostPosted: Fri Nov 21, 2008 1:54 pm    Post subject: Reply with quote

Hi andreasm,

Please contact PGI customer support at trs@pgroup.com. I think we'll need more information such as you're PIN number and license file but I rather you not post this information on a public forum.

Thanks,
Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Licenses and Installation All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group