PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

debugging in vs 2008 c++ to pvf
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
das



Joined: 02 Nov 2006
Posts: 4

PostPosted: Mon Jun 09, 2008 11:14 am    Post subject: debugging in vs 2008 c++ to pvf Reply with quote

Is there any trick to debugging mixed language c++ calling fortran in vs 2008? When I place a break in the c++ fortran call and try to step into the fortran, it steps over. When I try to put a break directly into the fortran the break is disabled saying that no symbols have been loaded for this file. What am I missing?
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Mon Jun 09, 2008 12:44 pm    Post subject: Reply with quote

Hi,

Are you using debugged version or release version? Please make sure your configuration is debug version?

Hongyon
Back to top
View user's profile
das



Joined: 02 Nov 2006
Posts: 4

PostPosted: Tue Jun 10, 2008 8:02 am    Post subject: Reply with quote

It is debug version, both the in c++ main that ouputs the executable and the pvf that is set to output a static library.
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Tue Jun 10, 2008 9:37 am    Post subject: Reply with quote

Hi,

You will need to set PVF project as a start up project. Then on a property page of PVF start up project -> Configuration properties -> Debugging, there should be a Command tab, you then enter a command(Path to C++ main program) and other environments variables.

Hongyon
Back to top
View user's profile
das



Joined: 02 Nov 2006
Posts: 4

PostPosted: Wed Jun 11, 2008 10:02 am    Post subject: Reply with quote

I made the PFV project the startup project and I set the command as the c++ exe and now it won't stop at breaks in either the fortran nor the c++ source. What am I missing?
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group