PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

pgprof text mode 7.1-3

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling
View previous topic :: View next topic  
Author Message
Alb



Joined: 26 Jul 2004
Posts: 16

PostPosted: Mon Apr 07, 2008 5:45 am    Post subject: pgprof text mode 7.1-3 Reply with quote

I am tring to run pgprof in text mode ( (on my SUSE LINUX Enterprise Server 9 jre is at version 1.4)) with the following command but the shell is just.. waiting
What am I missing?

pgprof -s -exe ./echam5 pgprof.out
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Mon Apr 07, 2008 9:42 am    Post subject: Reply with quote

Hi,

I am not sure. What were the flags do you use to compile? Is this 32-bit or 64-bit program? How did you set PATH environment variable?

Can you run a simple program such as hello program to see if it works?

Note that a text version does not use Java.

Hongyon
Back to top
View user's profile
Alb



Joined: 26 Jul 2004
Posts: 16

PostPosted: Mon Apr 07, 2008 10:27 am    Post subject: Reply with quote

thanks for your hint.
Indeed I was able to run pgprof on a simple program.
I rerun my original 64-bit one interactivly and now I have:

C-> pgprof -s -exe echam5.x pgprof.out
/opt/cluster/pgi/linux86-64/7.1-3/bin/pgprof: line 487: 14847 Segmentation fault $javaPATH $jMaxHeap "${jargs[@]}" -cp "$CP" $userRoot jpgprof "$path" "$@"
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Mon Apr 07, 2008 11:33 am    Post subject: Reply with quote

Hi,

Is it possible for you to send us both executables(echam5 and echam5.x) and pgprof.out?

Please send to trs@pgroup.com and tell them to forward the information to me.


Thank you,
Hongyon
Back to top
View user's profile
hongyon



Joined: 19 Jul 2004
Posts: 551

PostPosted: Wed Apr 09, 2008 12:45 pm    Post subject: Reply with quote

Hi,

We found a problem and unfortunately there is no workaround for it. This will be fixed in 7.2 release which is expected to come out some time in May.

Thanks for you patience.
Hongyon
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Debugging and Profiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group