PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

Free OpenACC Webinar

Link pb with acml

 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling
View previous topic :: View next topic  
Author Message
petrebang



Joined: 21 Apr 2006
Posts: 6

PostPosted: Mon Apr 24, 2006 7:37 am    Post subject: Link pb with acml Reply with quote

Hi all !

1 ) When I link my prog with -L/RepOfPgi/lib -lacml
I get this message :
"/usr/bin/ld: warning: libpgc.so, needed by /Produits/publics/x86_64.Linux.2.6.9/acml/3.1.0/pgi64/lib/libacml.so, not found (try using -rpath or -rpath-link)" and libpgc.so is present in libso rep.

but when I link with:
/RepOfPgi/lib/libacml.a
All is working fine.

Is the pb come from my installation of pgi ?
Thanks, Pierre.
Back to top
View user's profile
petrebang



Joined: 21 Apr 2006
Posts: 6

PostPosted: Mon Apr 24, 2006 7:55 am    Post subject: Reply with quote

It's OK, the pb come from the installation.
I forgot to add libso rep to LD_LIBRATY_PATH
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Programming and Compiling All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group