PGI User Forum
 SearchSearch   MemberlistMemberlist     RegisterRegister   ProfileProfile    Log inLog in 

CUDA-x86.

Device kernel error (are maths operations the problem?)
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming
View previous topic :: View next topic  
Author Message
Torkin



Joined: 18 Apr 2012
Posts: 31

PostPosted: Mon Apr 28, 2014 3:44 pm    Post subject: Reply with quote

Uploaded

- Ahmed
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Mon Apr 28, 2014 4:42 pm    Post subject: Reply with quote

Great. It looks like you have a number of errors in your program unrelated to CUDA Fortran. Adding "implicit none" would have helped here since a few of the errors were mismatched types and using an undefined variable as the size of an allocatable. The one CUDA Fortran error I saw was that you were passing a device scalar by value to a kernel. Only host variables should be passed by value.

I've sent you the changes I've made and was able to run the program to completion. There's probably additional issues, but I'll let you take it from here.

Hope this helps,
Mat
Back to top
View user's profile
Torkin



Joined: 18 Apr 2012
Posts: 31

PostPosted: Mon Apr 28, 2014 4:50 pm    Post subject: Reply with quote

Dear Mat

I really appreciate you going through these lengths with me. I owe you a cup of coffee.

Thank you

- Ahmed
Back to top
View user's profile
Torkin



Joined: 18 Apr 2012
Posts: 31

PostPosted: Mon Apr 28, 2014 6:40 pm    Post subject: Reply with quote

Dear Mat

I got it to work! You are always helpful, one of a kind.
It is 3:40 am here and I am extremely happy with my working code, thanks to you!

- Ahmed
Back to top
View user's profile
mkcolg



Joined: 30 Jun 2004
Posts: 6134
Location: The Portland Group Inc.

PostPosted: Tue Apr 29, 2014 5:06 pm    Post subject: Reply with quote

That's great Ahmed. Now get some sleep!

- Mat
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    PGI User Forum Forum Index -> Accelerator Programming All times are GMT - 7 Hours
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group